NPC animation help (falls over)

Discussion in 'Mapping Questions & Discussion' started by Niodyne, Dec 6, 2009.

  1. Niodyne

    Niodyne L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    I searched for awhile and couldn't find the answer, so...

    I try to make the heavy NPC do taunt05 over and over. I can setup it up, but at the end of the taunt he falls on his side for a moment then restarts the animation normally (standing up). In the model browser a lot of the animations I browse also have him on his side and not standing up. The only taunt not broken is 06.

    I'm guessing there's an easy fix I'm just not finding, any help?
     
  2. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
    Trigger animation manually with correct timing?
     
  3. Niodyne

    Niodyne L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Timing... so cut it off before it gets to that point? Guess I can do that.

    I noticed some animations seem to be completely off axis/balance/whatever for the whole thing. Just avoid those?

    On a related note, can I disable sounds the heavy makes when taunting? I have him doing kgb taunt and spawning stuff in front of him, like he's throwing it, but he goes ding ding ding ding all the time.
     
  4. Jimbomcb

    Jimbomcb L1: Registered

    Messages:
    27
    Positive Ratings:
    2
    I'm fairly sure them animations where they're on their side should work fine (or at least work on a player fine), I always assumed that was animations for only specific parts of the model letting the rest carry on with their own animation

    though i could be (and probably am) way off
     
  5. The Asylum

    aa The Asylum

    Messages:
    1,658
    Positive Ratings:
    439
    There's this one achievement idle map called achievement_idle_ultimateV103, which uses lots of NPC animations. Use VMEX to decompile it, and see what they've done
     
  6. Niodyne

    Niodyne L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Thanks for all the suggestions!

    I read something about it having things default to the Y axis and that messing it up when people try to decompile and mod. They seem to fall to the Y axis, so that might have something to do with it.
     
  7. Swiftmind

    Swiftmind L2: Junior Member

    Messages:
    73
    Positive Ratings:
    20
    The reason why you are seeing this is because most animations are only for one part of the model (I think). These animations are played on one part while the rest of the model reacts to the players commands and what not.

    Do not use the model viewer, it will not show all the animations. Within the prop_dynamic's properties, go to the model tab. Here is all the animations you can pick and they will play on the model in your map. Some animations will work others will not, you need to test them out.

    For taunts, pick the taunt animations that start with "layer_". For instance on a heavy do "layer_taunt02".


    If the one you want still does not work within the model tab, you will need to make a custom animation.

    Hope that helps!
     
    • Thanks Thanks x 1
  8. Niodyne

    Niodyne L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Wow thank you! I completely missed the layer_taunts. They work great.

    Also for my other question, was there a way to disable sounds playing for animations and/or func_regen? Maybe something complex like packaging an empty sound file into the bsp or anything?
     
  9. Swiftmind

    Swiftmind L2: Junior Member

    Messages:
    73
    Positive Ratings:
    20
    Your welcome.

    Ummm, be careful with that. The source engine loads stuff into RAM once and will continuously use it until it is unneeded. If you replace the resupply locker sound, all maps following yours will have your custom sound....well I never tried this with sound but this did happen to me when I was replacing skins for the prop_gameplay signs. All the maps following mine had my custom skin. This of course happened when I played my map first. While now that I think of it I did not do a regular map first then mine then another.

    As far as I know there is no way to remove the sounds from animations, unless you create your own animation. I am figuring that you will just need to deal with the sound.
     
    • Thanks Thanks x 1