Not a "I got this weird compile error" just a compile question.

Discussion in 'Mapping Questions & Discussion' started by Kraftwerk, Aug 16, 2009.

  1. Kraftwerk

    Kraftwerk L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    Whenever I compile my map, the "portal vis" or whatever takes about 20 minutes. Any idea how I can optimise this or fix it?
     
  2. Altaco

    Altaco L7: Fancy Member

    Messages:
    485
    Positive Ratings:
    121
    This basically means you have a lot of visleaves. You probably have some complicated geometry (like stairs, angular shapes, anything significantly more complicated than a block) which splits up the map and causes extra calculations. You can fix this by making complex geometry (which doesn't seal the map from the void) func_detail entities.

    See this tutorial for help on optimization, which done properly can reduce your compile time to a fraction of what it is now and increase ingame performance: http://optimization.interlopers.net/index.php?chapter=intro
     
    • Thanks Thanks x 1
  3. Kraftwerk

    Kraftwerk L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    Ooh! This is very helpful, (I have a lot of curves) but 1 thing, I thought "Func detail" makes them so you can walk through them. Am I just mistaken?
     
  4. Nutomic

    Nutomic L11: Posh Member

    Messages:
    888
    Positive Ratings:
    177
    Yes your wrong, func_details act just like normal brushes (except for a little bug i think), that means their totally solid. The only thing they do is tell the compiler to ignore them when making the visibility calculation, so there is less brushes to calculate.
     
  5. Kraftwerk

    Kraftwerk L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    Well, I did that, but the thing right after baseportal flow takes a ridicuously long time to compile (fifteen minutes). What else can I do?
     
  6. Altaco

    Altaco L7: Fancy Member

    Messages:
    485
    Positive Ratings:
    121
    After you compile, go to map > load portal file. This will let you see the way visleaves are being cut up and find what geometry is causing it.

    I suppose also make sure you don't have any leaks.
     
  7. Garner

    Garner L4: Comfortable Member

    Messages:
    154
    Positive Ratings:
    38
    Unfortunately, this is normal (well the length of time depends on your CPU and RAM). When i compiled a map for a friend a while ago (his comp was rubbish), the vis part of the compile took me 15mins (and my hammer appeared to be not responding) but i left it on, went to the shops and when i came home it had finished.

    Basically, the vis part is one of the most important parts, as it determines what is visiable. My compile times as slightly quicker cause i use areaportal brushes w/func_areaportal applied to them, hint/skip brushes to divide visleaves ect.

    But, the timeframe of 15mins for me only applies to BIG maps, small maps take around 2 to 3 mins, and test maps like small maps i make to test something out with 1 or 2 rooms take seconds to compile (maybe a minute with HDR enabled)

    Maybe if you listed your comp spec we may be able to tell you if your comp is up to the task of compiling.
     
    • Thanks Thanks x 1
  8. Kraftwerk

    Kraftwerk L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    My specs: 1.7 ghz quad core procecsor.
    4 gb of ram
    Nvidia 9500 GT (Although that doesn't have to do with compiling)
    Also: My map is one fourth max size, it is quite large.
     
  9. Garner

    Garner L4: Comfortable Member

    Messages:
    154
    Positive Ratings:
    38
    hmm 1.7ghz quad core?

    Whats the CPU model? because your CPU seems to be underclocking (i dont think there is a quad core processor with a stock clock of 1.7ghz)
     
  10. Kraftwerk

    Kraftwerk L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    OK: Problem solved. I removed all water and things worked just fine, compiled near instantly.
     
  11. Kraftwerk

    Kraftwerk L2: Junior Member

    Messages:
    86
    Positive Ratings:
    4
    NM its 1.8 ghz. not 1.7. If I get brave, I might over clock it.
     
  12. Garner

    Garner L4: Comfortable Member

    Messages:
    154
    Positive Ratings:
    38
    The thing is, iv never heard of a 1.8ghz Quad CPU, so im thinking that you have SpeedStep enabled (which underclocks your CPU). I had a similar problem, and had to go into BIOS and disable it.

    At the time, my Q6600 was running at 1.2ghz, despite being a 2.4ghz processor. Disabling Speedstep meant it ran everything with 2.4ghz of power.

    If this may be the case with you, then it would mean your compile times are hindered cause of your underclocked CPU.
     
    • Thanks Thanks x 1
  13. Vigilante212

    Vigilante212 L7: Fancy Member

    Messages:
    481
    Positive Ratings:
    33
    It only idles down when its not doing anything when he runs a compiler itll auto idle back up thier no real need to disable it its a power saving feature.