(Noob Question) Where are my Props?

Discussion in 'Mapping Questions & Discussion' started by wataru8675, Jun 30, 2012.

  1. wataru8675

    wataru8675 L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    So I'm sure this is probably going to end up being a REALLY easy question to answer, but I've searched through the forums and the VDC to no avail -- I'm guessing it's just an issue of not knowing what to search for.

    Anyway -- when I create an entity and change it to a prop_static type, I'm not able to see any models in the "World Model" browser. A small handful come up, but they're not stock props like I want...they're all from various custom themes that I've picked up here and there while playing (e.g. when I click props_pipes, props_nucleus, props_nightfall, et. all, the sub-file browser says "No .mdl files"). I'm not looking to do anything too complicated with it. I kind of just decided to make a "junk yard" themed dm map to start myself off, so I basically just have some displaced terrain that I'm scattering various props around for cover and the like.

    Thanks for any help! I'm sure it's just going to be a matter of me checking a box or something.
     
  2. colacan

    colacan L5: Dapper Member

    Messages:
    235
    Positive Ratings:
    66
    Is the filter box empty? props_pipes etc. are the default subfolders and there should be props in it. And set the mod filter to All Mods, just don't use the HL2 ones.
     
  3. wataru8675

    wataru8675 L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    The Mod Filter box has 3 instances of HL2 and 2 instances of TF. I tried both TF instances and got the same result, and changing it to All Mods doesn't give me much more variety anyway (in fact, I think the only difference is that now I just get a handful of HL2 props).
     
  4. Faux Rhinoceros

    aa Faux Rhinoceros Also known as Dr. Element

    Messages:
    1,479
    Positive Ratings:
    1,368
    [​IMG]

    There are four elements you must be aware of, all marked here with a red arrow. If you set them all exactly like in this screenshot, it should show you every single model available.

    (Model filter = All mods
    Check subfolders = checked
    "MDL files" chosen by clicking on it
    Filter = blank

    If you are looking for something specific, you can type a keyword in the "filter" bar)
     
    • Thanks Thanks x 2
    Last edited: Jun 30, 2012
  5. wataru8675

    wataru8675 L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    Bleeeech, yup -- it was a stupid fix alright. I had "tf" in my filters from when I was futzing around trying to get it to work. Thanks so much for the dumb version, Dr. Element. I appreciate it!
     
  6. Faux Rhinoceros

    aa Faux Rhinoceros Also known as Dr. Element

    Messages:
    1,479
    Positive Ratings:
    1,368
    No problem ;)

    Here, have my 300th post :p
     
    • Thanks Thanks x 1
  7. wataru8675

    wataru8675 L1: Registered

    Messages:
    6
    Positive Ratings:
    0