NODRAW ON COMPILING LOG, BUT NO NODRAW ON MAP

Discussion in 'Mapping Questions & Discussion' started by Lightyena, Nov 10, 2018.

  1. Lightyena

    Lightyena L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    I'm a beginner in map creation,
    This is my second map, I did not have this problem on my first map.
    but well...

    I have a strange problem on my map and I do not know how to solve it myself.

    like being in the title, I do not have any nodraw texture on my map, but in the log it accuses an error about it and does not let the map finish being compiled because of that.

    here log...

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Users\Pichau\Desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1.vmf"

    Valve Software - vbsp.exe (Aug 2 2018)
    8 threads
    materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Users\Pichau\Desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1.vmf
    Patching WVT material: maps/mvm_snowtown_b1/nature/blendrockgroundwallsnow_wvt_patch
    Patching WVT material: maps/mvm_snowtown_b1/pl_barnblitz/blendmetalroofsnow_02_wvt_patch
    Patching WVT material: maps/mvm_snowtown_b1/pl_barnblitz/blendsnowtodirt001_wvt_patch
    Patching WVT material: maps/mvm_snowtown_b1/nature/blendrockgroundwallforest_wvt_patch
    Patching WVT material: maps/mvm_snowtown_b1/pl_barnblitz/blendmetalroofsnow_03_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Processing areas...done (0)
    Building Faces...done (0)
    Chop Details...done (0)
    Find Visible Detail Sides...
    Merged 296 detail faces...done (0)
    Merging details...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    NODRAW on terrain surface!
    done (0)
    writing C:\Users\Pichau\Desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1.prt...Building visibility clusters...
    done (0)
    *** Error: Skybox vtf files for skybox/sky_stormfront_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_stormfront_01 to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_stormfront_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_stormfront_01 to build the default cubemap!
    Finding displacement neighbors...

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -fast "C:\Users\Pichau\Desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1"

    Valve Software - vvis.exe (Aug 2 2018)
    fastvis = true
    8 threads
    reading c:\users\pichau\desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1.bsp
    Error opening c:\users\pichau\desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1.bsp

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Users\Pichau\Desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1"

    Valve Software - vrad.exe SSE (Jul 18 2018)

    Valve Radiosity Simulator
    8 threads
    [Reading texlights from 'lights.rad']
    unknown light specifier type - lights

    [56 texlights parsed from 'lights.rad']

    Loading c:\users\pichau\desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1.bsp
    Error opening c:\users\pichau\desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1.bsp

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Users\Pichau\Desktop\tf2 mvm maps\why-it-happen\mvm_snowtown_b1.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\mvm_snowtown_b1.bsp"

    The command failed. Windows reported the error:
    "O sistema não pode encontrar o arquivo especificado."

    ps: I'm Brazilian, so the last line of the log is not in English
     
  2. OctoBlitz

    OctoBlitz L6: Sharp Member

    Messages:
    279
    Positive Ratings:
    108
    • Thanks Thanks x 1
  3. Micnax

    aa Micnax Back from the dead (again)

    Messages:
    2,104
    Positive Ratings:
    1,562
    Do you have any displacements in your map?
     
    • Thanks Thanks x 1
  4. Lightyena

    Lightyena L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    I already checked the site about my error, there is not exactly what happens

    yes, I have but I'm only using texture of rocks and snow on it,
    also did the test deleting all the displacements of the map and even then the error happens
     
  5. Lightyena

    Lightyena L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    I already fixed that, it was the player_clip that I used as displacement, I did not know that the hammer indended player_clip how a nodraw... this is stupid