nobuild not working

Discussion in 'Mapping Questions & Discussion' started by Alizée Fan, Dec 17, 2008.

  1. Alizée Fan

    Alizée Fan L1: Registered

    Messages:
    13
    Positive Ratings:
    0
    Hello all!

    I've been working on my first full-scale map for release, and have got it to the point I'm almost ready to start play-testing it with real people, except for one thing - none of my nobuild zones work.

    Neither of my func_respawn areas are preventing engineers from building stuff. I'm quite perplexed by this, as other aspects like the free class-switching in that area is working perfectly.

    Just for good measure, I tried adding some func_nobuild areas in a different place, to see if I could use that as a workaround, and func_nobuild isn't working either.

    I feel like I'm probably missing something very obvious, like a little switch or something that's flipped to ignore nobuild zones, but I'll be darned if I can find it! I took a look through the various tutorials and help threads here, which have been a huge help to me during my learning process (thank you all!), but couldn't seem to find it. If anybody has an idea how to resolve this, I would be very appreciative.

    <eVa> Alizée Fan
     
  2. bob+M|M+

    bob+M|M+ L6: Sharp Member

    Messages:
    348
    Positive Ratings:
    185
    The only thing I can think of is your triggers aren't touching the floor. This would make sense because you would still be able to change classes if the trigger was raised to mid-body height.
     
  3. UKCS-Alias

    aa UKCS-Alias Mann vs Machine... or... Mapper vs Meta?

    Messages:
    1,264
    Positive Ratings:
    749
  4. Xi.Cynx

    aa Xi.Cynx Former Alias: †Blade†

    Messages:
    772
    Positive Ratings:
    734
    yea make sure they go all the way through the floor or at least into it if not on a ledge and even over the edge a little bit if on a ledge. Make sure all the brushes are at least touching the floor for your respawn areas. The reason the free class-switching does work is cause the players body is still inside the trigger somewhere. Even if it was only their head that was inside the trigger it would still work. That's why valve stress's to make sure in a respawn room make sure the trigger touches every wall/floor/ceiling so everything works properly.
     
  5. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    145
    It says 96 units to either side of there you want it to be
     
  6. Alizée Fan

    Alizée Fan L1: Registered

    Messages:
    13
    Positive Ratings:
    0
    Ahh, ok, hmm. I was using the floor itself as my func_respawn, rather than having seperate ones. I'll give it a go with your advice to make it bigger, seperate, and encompassing. Thanks for the tips!

    -----------edit-------------

    Works perfectly now! Thanks all :)
     
    Last edited: Dec 18, 2008