No compile errorrs but no map in TF2

Discussion in 'Mapping Questions & Discussion' started by Roland, Mar 27, 2012.

  1. Roland

    Roland L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Hi,
    I am hoping someone can help me get my map back into a shape which I can test.
    I have checked these forums to no avail and used the interlopers website to check my compile log, which according to that is fine. Although my map seems to compile and TF2 launches fine when I 'run map', it is not there to play when I select 'start playing' from the tf2 menu, I'm just faced with the standard options for game types.
    I have dealt with a few compile errors using info from the web for TF2 and CS, but this one has me stuck...
    Any help greatly appreciated, I can always post the log if that helps.
    Thanks in advance.
     
  2. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    The Start Playing menu is a quick-join function for joining servers. You need to either hit the Create Server button (plus sign on top of the browse button) and pick your map from the list, or start it through the console (~ key. options > keyboard > advanced to enable it, if you never have) and type map with the name of your map after it.
     
    • Thanks Thanks x 1
  3. Roland

    Roland L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Strange, I am sure it was working through the Start Playing option before I added all the koth related entities, but now only if I create a server and select it from a list, as you suggest.

    Thanks very much for your help.