New laptop, TF2 locked at 30FPS, any ideas?

Discussion in 'Team Fortress 2 Talk' started by x6herbius, Apr 17, 2019.

  1. x6herbius

    aa x6herbius

    Messages:
    383
    Positive Ratings:
    282
    I bought a new Dell XPS laptop lately - this is an 8th gen i7, NVIDIA GeForce GTX 1050 Ti machine, so shouldn't have any problems running TF2 in theory. However, I'm finding that when I run the game, my FPS is always fluttering around 30 (give or take +/- 1), which makes me suspicious that there's some sort of frame rate lock applied somewhere. There's also about half a second of input lag.

    [​IMG]

    This is on empty 2Fort, and no graphics settings that I change seem to make any difference. Vsync is not switched on in game or in the NVIDIA control panel, and it's definitely starting up on the NVIDIA GPU rather than the Intel one.

    This is my first foray into Windows 10 (I really dislike it, and run Linux at home, but I'm seeing if it's workable on this laptop at least for now). Is there anything I might need to turn off to fix this? Has anyone come across anything like it before?

    EDIT: For the sake of posterity, I've tried changing the following to no effect:
    • Focus assist
    • Game bar
    • Game mode
    • System power saving mode
    • Vsync (in TF2 and in NVIDIA control panel)
     
    Last edited: Apr 17, 2019
  2. comradecommie

    comradecommie L3: Member

    Messages:
    138
    Positive Ratings:
    48
  3. x6herbius

    aa x6herbius

    Messages:
    383
    Positive Ratings:
    282
    Yep, just tried that, nothing.
     
  4. DrSquishy

    aa DrSquishy ???

    Messages:
    1,211
    Positive Ratings:
    779
    Try putting -gl in your launch options - it means TF2 will run on OpenGL, perhaps that'll help for you
     
  5. x6herbius

    aa x6herbius

    Messages:
    383
    Positive Ratings:
    282
    OK, after a lot of searching and a lot of GeForce Experience BS, I found this:

    [​IMG]

    Apparently this is turned on by default. I turned it off and now my FPS is capped at 60. Better, but not ideal - I'm now going through the rigmarole of updating the GPU drivers (which keep failing), and will see if that solves the rest.
     
  6. Jeff Magnum

    Jeff Magnum L1: Registered

    Messages:
    25
    Positive Ratings:
    17
    Are you running TF2 in windowed/borderless windowed? If you are, Windows 10 forces triple buffering via its Desktop Window Manager (https://en.wikipedia.org/wiki/Desktop_Window_Manager) - this can't be turned off except by running the game in fullscreen proper.
     
  7. x6herbius

    aa x6herbius

    Messages:
    383
    Positive Ratings:
    282
    That's useful to know. I think the graphics driver update fixed it, but it could potentially still be due to some power settings. I'll see how things go in the next few days.