Need some help with shadows

Discussion in 'Mapping Questions & Discussion' started by Pearl, Mar 30, 2016.

  1. Pearl

    Pearl L1: Registered

    Messages:
    11
    Positive Ratings:
    2
    How do you fix this issue?

    [​IMG]
     
  2. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,629
    Positive Ratings:
    1,715
  3. Dr. Orange

    Dr. Orange L6: Sharp Member

    Messages:
    368
    Positive Ratings:
    278
    Simply disable shadows on your track models.
     
  4. Pearl

    Pearl L1: Registered

    Messages:
    11
    Positive Ratings:
    2
    Valve map's don't disable shadows on there tracks... I was wanting to know how they did it.

    [​IMG]
     
  5. sooshey

    aa sooshey :3c

    Messages:
    522
    Positive Ratings:
    418
    That's because they used a lengthy VRAD process to make their track shadows look good. Unfortunately this also makes the compile take an absurdly long time. So for maps in development, disabling track shadows works for the time being, allowing you to do faster compiles as you constantly edit the map. This thread explains how to remove the shadows (the long way) if you want to know.
     
  6. Pearl

    Pearl L1: Registered

    Messages:
    11
    Positive Ratings:
    2
    Hopefully I can figure the long way out...
     
  7. Pearl

    Pearl L1: Registered

    Messages:
    11
    Positive Ratings:
    2
    Thanks btw
     
  8. henke37

    aa henke37

    Messages:
    1,919
    Positive Ratings:
    449
    The "lengthy VRAD process" is nothing more than setting the -StaticPropPolys flag when running vrad. I don't think it's particularly expensive.