Need help with textures not being available.

Discussion in 'Mapping Questions & Discussion' started by Spade, Aug 29, 2015.

  1. Spade

    Spade L1: Registered

    Messages:
    6
    Positive Ratings:
    3
    When I open up Hammer it is normal, but when I click File > New. It pops up this message "No textures are available for use with that game. You must set them up in the Textures tab of the Options dialog box before you can edit maps for this game." Next I clicked "Ok" then it brings up the "Configure Hammer". I looked under everything for hours and came up with nothing. Anyone know how to get the textures to become available?
     
  2. Crash

    aa Crash func_nerd

    Messages:
    3,074
    Positive Ratings:
    4,563
    How are you launching Hammer?
     
    • Thanks Thanks x 1
  3. Spade

    Spade L1: Registered

    Messages:
    6
    Positive Ratings:
    3
    I am launching Hammer from my taskbar.
     
  4. Crash

    aa Crash func_nerd

    Messages:
    3,074
    Positive Ratings:
    4,563
    But that's linking to Hammer in your bin folder? Just checking to see if you are doing it via the SDK or not. That can cause an issue like you have.
     
    • Thanks Thanks x 1
  5. MoonFox

    MoonFox L10: Glamorous Member

    Messages:
    735
    Positive Ratings:
    72
    I would say, even if you are launching from the Bin folder, do a content check periodically on Source SDK
     
    • Thanks Thanks x 1
  6. Spade

    Spade L1: Registered

    Messages:
    6
    Positive Ratings:
    3
    Ok I will try that, I will let you know of the result.
     
  7. Spade

    Spade L1: Registered

    Messages:
    6
    Positive Ratings:
    3
    Ok good news and bad news. Good news I do not seam to have that problem now. Bad news is I have this message when trying to make a new map "Failed to load the default scheme file. The map view may be missing some visual elements." When I click "Ok" it brings up four black boxes and some white lines. When I use the [ and ] keys the white lines do not change. I can not make any brushes. But at least the custom textures seam to be in here. Also I cant find the team fortress textures (I look under tf and nothing shows up exept 3 grey textures) Further more, when I try to open a already made map it says this "Model models/props_gameplay/resupply_locker.mdl not found and models/error.mdl couldn't be loaded."
     
  8. Osspial

    Osspial L2: Junior Member

    Messages:
    64
    Positive Ratings:
    73
    When you launch Hammer, there should be a window on the bottom of the screen called "Messages". If it's not there, you should be able to open it by going into the "Tools" drop-down menu. Anyway, once you've found it it should display multiple lines reading something along the lines of "Search Path (GAME): [Steam directory]\steamapps\common\team fortress 2", continued by the locations of various ".vpk" files in the TF2 directory. Does it show this?
     
  9. Crash

    aa Crash func_nerd

    Messages:
    3,074
    Positive Ratings:
    4,563
    It really sounds like you are opening Hammer the old way (through the SDK) rather than the new way (in the bin folder)

    This video shows you exactly where to open it (starting at around 1:20)
     
    • Thanks Thanks x 2
  10. Spade

    Spade L1: Registered

    Messages:
    6
    Positive Ratings:
    3
    I opened Hammer as told to do so in the video. Unlike opening it in SDK it has red text in the messages box. It says "Invalid game "G:\steam\steamapps\common\team fortress 2\tf" found in VPROJECT environment variable, ignoring." Once again I am getting the message saying "No textures are available for use with that game. You must set them up in the Textures tab of the Options dialog box before you can edit maps for this game." When I try to make a new map. Also yes it is followed by some .vpk files.
     
  11. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,213
    Hmm. It might be that Hammer can't cope with TF2 being in a custom location.
     
  12. Spade

    Spade L1: Registered

    Messages:
    6
    Positive Ratings:
    3
    Sorry it took me so long to reply, but where is the default location supposed to be sir?
     
  13. hutty

    aa hutty

    Messages:
    449
    Positive Ratings:
    345
    Have you tried validating tf2's files through steam?
    (right click on tf2 in steam -> properties -> content or something)
     
  14. Davekillerish

    aa Davekillerish Lvl O: Orange Member

    Messages:
    1,430
    Positive Ratings:
    794
    Shameless self advertisement :p