Need help with some models in game.

Discussion in 'Mapping Questions & Discussion' started by Zengineer, Mar 17, 2013.

  1. Zengineer

    Zengineer L1: Registered

    Messages:
    3
    Positive Ratings:
    1
    [​IMG]
    [​IMG]

    I'm encountering a problem I wish to correct.

    While in-game, these models turn into the dreaded ERROR model, even though it comes up perfectly fine in Hammer. These models are prop_dynamics, and I don't know what's causing them to disappear and be replaced by ERROR. Please help by telling me what's wrong and what to do. Thank you.
     
  2. Spacek531

    Spacek531 L4: Comfortable Member

    Messages:
    162
    Positive Ratings:
    60
    first, since I presume they don't move, make them prop_static instead of prop_dynamic. If that doesn't work then I don't know what you can do other than checking to see if it's a non-tf2 model.
     
    • Thanks Thanks x 3
  3. henke37

    aa henke37

    Messages:
    1,864
    Positive Ratings:
    432
    I think the only stuff here that is from tf2 is the white pipes.
     
  4. Burnout6010

    Burnout6010 L5: Dapper Member

    Messages:
    207
    Positive Ratings:
    23
    The big pipe is the Well drop from the team's base to the water, just here it's from outside
     
    • Thanks Thanks x 1
  5. DonutVikingChap

    DonutVikingChap L5: Dapper Member

    Messages:
    226
    Positive Ratings:
    142
    I had the same problem when making prop_details. (Specifically small cans and misc. decoration from props/2fort.) Once I turned them into prop_statics they worked fine.

    I don't see why you'd want those to be prop_dynamics, though.
     
  6. Faux Rhinoceros

    aa Faux Rhinoceros Also known as Dr. Element

    Messages:
    1,474
    Positive Ratings:
    1,365