My water isn't showing up

Discussion in 'Mapping Questions & Discussion' started by CrippledDonut!, Aug 3, 2017.

  1. CrippledDonut!

    CrippledDonut! L1: Registered

    Messages:
    38
    Positive Ratings:
    1
    I put water in my map but when I load up the map the water does not appear. anyone know how to fix this
     
  2. RodionJenga

    RodionJenga L5: Dapper Member

    Messages:
    234
    Positive Ratings:
    239
    Check for leaks. Leaks cause water to be invisible.
     
  3. HolySnickerPuffs

    aa HolySnickerPuffs Bad at TF2, Loves Mapping For TF2

    Messages:
    931
    Positive Ratings:
    1,255
    Well, you need the water_lod_control entity. Make sure you put that in your map.

    Also don't use the "Fast" settings when compiling you map. That also donks it up for some reason.
     
    • Respectfully Disagree Respectfully Disagree x 1
  4. CrippledDonut!

    CrippledDonut! L1: Registered

    Messages:
    38
    Positive Ratings:
    1
    Thanks, I fixed it. Their was a leak that I fixed
     
    • Like Like x 1
  5. BigfootBeto

    aa BigfootBeto Too obsessed with perfection

    Messages:
    381
    Positive Ratings:
    582
    I like how fixing a leak actually makes water appear cause a real life leak makes water disappear also.
    Also, if there's water on your map, I would suggest hanging it up to dry somewhere cause soggy paper is very fragile.
     
    • Funny Funny x 4
  6. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,387
    Positive Ratings:
    4,220
    water_lod_control can be handy, but you don't need it to make water render properly in your map - the compiler will just use the default LOD settings.

    Also, Fast compiles are useful for testing purposes (and I've never had it screw up water in my map before)
     
    • Agree Agree x 3
  7. henke37

    aa henke37

    Messages:
    1,913
    Positive Ratings:
    447
    vbsp just adds the water_lod_control entity for you if you don't have one and have water in the map.
     
    • Thanks Thanks x 1