1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

My tree is fullbright what is this

Discussion in 'Mapping Questions & Discussion' started by Bacteriophage, Oct 8, 2009.

  1. Bacteriophage

    Bacteriophage L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    [​IMG]

    I put in an env_light a while ago and just took a shot at plopping some trees. But as you can see, they look fullbright despite the map being properly lit.

    I used the Sawmill settings from Valve for the env_light. Any clue why my tree isn't lighting as it should?
     
  2. PL-7764

    PL-7764 L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    84
    I can see small shadows on it in the picture, mostly towards the left side of it (under the branches, on the main trunk at the bottom). I think the shading on the trees might just be a little more subtle than with other models.

    Or it might be broken and I just can't tell... I still think it looks alright.
     
  3. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,480
    You need to compile with [ame=http://forums.tf2maps.net/showthread.php?t=2994]-staticproppolies[/ame] enabled.
     
  4. jpr

    aa jpr

    Messages:
    1,095
    Positive Ratings:
    543
    Off topic, but do you happen to be the baceriophage from mfgg?
     
  5. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,920
    WRONG WRONG WRONG WRONG

    -staticproppolys is for lightmap shadows cast around the actual prop instead of it's collision mesh.

    -staticproplighting is what you want to give nice shading on your tree.

    I'll give a little bit more explaination: your tree isn't fullbright, but the entire tree has the same light applied to it, this is the default way hammer compiles but since either episode 1 or 2 is no longer the standard for the source engine, as you'll notice the trees in TF2 are shaded nicely, this is because each vertex on the tree has it's own lighting information so the side away from the light is in shade.

    As a side note to everyone else: please make sure you're actually correct when you dish out one liner answers with no explaination!!!
     
  6. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,480
    I knew it was one of those. Anyway, beware, -staticproplighting will increase your map size by an awful lot.
     
  7. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,920
    Again thats quite incorrect. staticproplighting doesn't add to filesize, not using it decreases filesize

    Since it's now the source standard, if you don't use it you're misrepresenting the source engine and you gotta start thinking about these 'extra' options as the standard. Since that's what they are.
     
  8. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,538
    and it's worth noting that you can disable the vertex lighting enabled by -staticproplighting on a per-prop basis with a key in the entity properties. yet another facet to optimization.
     
  9. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,480
    I have been shown who is the boss! :eek:hmy:
     
  10. Bacteriophage

    Bacteriophage L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    The very same.

    Thanks for the help, mentlegen