Missing Textures

Discussion in 'Mapping Questions & Discussion' started by xomp, Aug 10, 2014.

  1. xomp

    xomp L1: Registered

    Messages:
    33
    Positive Ratings:
    8
    I'm using Pakrat095 to pack textures into my map. I'm then using the steps below to build the cubemaps:

    Code:
    Building cubemaps for LDR & HDR(recommended)
    -mat_specular 0
    -map <mapname>(Load your map)
    -buildcubemaps
    -disconnect
    -mat_hdr_level 0
    -map <mapname>
    -buildcubemaps
    -disconnect
    -mat_specular 1
    -mat_hdr_level 2
    -map <mapname>(Load different level; clears texture cache)
    -map <mapname>(Load your map again)
    After all is said and done, I upload the finished product to my server and have a few people report any problems. Here's what we get.

    For me, the map looks 100% fine, no missing textures.

    For person B they only have a few missing textures here and there but most of the map-say 98% is fine.

    For person C they have about 60% missing textures.

    To say I'm thoroughly confused would be putting it lightly. Any ideas why this would happen?
     
  2. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    It has nothing to do with the cubemaps.
    PakRat is broken and won't pack the textures of models. The reason the other person could see a few more then the other guy is that he is either a mapper and has the custom content on his PC already, or the map he played previous had the same custom textures.

    I recommend switching to VIDE to pack custom content. Its a bit difficult to understand so watch a tutorial first
     
  3. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    One day, one poster:

    "X is broken. Use Y."

    Another day, another poster:

    "Y is broken. Use X."
     
  4. henke37

    aa henke37

    Messages:
    1,921
    Positive Ratings:
    450
    X and Y are broken, use bspzip.
     
  5. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    X is broken. give up. come back later when it magically works for no reason.
     
  6. wareya

    wareya L7: Fancy Member

    Messages:
    493
    Positive Ratings:
    173
    i just use bspzipgui
     
  7. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    vide master race