Missing textures/pakratting issue.

Discussion in 'Mapping Questions & Discussion' started by Foxyfluff, Dec 2, 2014.

  1. Foxyfluff

    Foxyfluff L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    Hey there.

    I finished up my map, compiled it and was looking to make the final .bsp file by inserting my custom textures/materials/logos.

    Said textures show up just fine in Hammer. They also show up when running the map without my materials folder renamed to replicate a random client.

    I've repeated the process of compiling the map and pakratting the .bsp several times without any improvements.

    All the custom textures are present when inspecting the .bsp with pakrat.

    I had a more expierenced friend attempt to pakrat it as well just to make sure I didn't slip up, but still no luck.

    What may be causing this?

    The In-Game console says this:

    Code:
    *** Encountered VTF file with an invalid minor version!
    *** Encountered VTF file with an invalid full header!
     
  2. Lampenpam

    aa Lampenpam

    Messages:
    994
    Positive Ratings:
    329
    What's excatly the problem? Do the textures not showup for others in game?

    Try to pack the map with VIDE. pakrat is old and broken
     
  3. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,818
    Positive Ratings:
    4,660
    Pakrat is old but it's not broken at all. In fact it works better than vide in a lot of places....regardless, pakrat, like vide, is just a GUI for bspzip, the tool valve provides.

    This sounds like a problem with the version of VTF you're using. Newer games have newer vtf types. Try re-exporting them using vtfedit or the photoshop plugin. If all else fails, use vtex from the tf2 folder itself to get the correct version.
     
  4. Foxyfluff

    Foxyfluff L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    Oh I'm sorry, forgot to actually specify the issue.

    All my custom textures/logos are purple In-Game.

    I will try this.