Missing model textures/pakrat

Discussion in 'Mapping Questions & Discussion' started by grazr, Oct 1, 2010.

  1. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,573
    I've used pakrat to pack my custom gear into my map. Running the map on my local computer shows the model textures fine, even after disabling the respective folders to double check for errors/missing textures.

    So textures appear fine locally, but not on the TF2maps servers. The haybale textures appear fine so it's not like i didn't understand where the model materials are located, and i've attempted to rectify this (pumpkin and crocodile clips) twice now to no avail.

    The only thing i am aware of that is different is that Acumen left out the models material substance in the qc so i could modify (override) the vmt manually to save him recompiling the model for each substance option. In the end i left it out because i disabled the collision besides vs the world and it was no longer necassery to specify the material.

    This should just mean it defaults, which it does, or so it appears on the listen server. Yet the TF2maps server simply wont display the custom pumpkin/croc-clip materials.
     
  2. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,573
    Dark unpacked the bsp the other day and the files are present in the packed bsp.

    Grim can't seem to see them on a local server on his machine, though Snacks apparently can.

    So confusing.
     
    Last edited: Oct 2, 2010
  3. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,573
    Ok, well it seemed to be working on the server a moment ago. On both the fresh artpass_grazr2 and when i loaded the original, artpass_grazr.

    I thought it might have been a DX issue but this doesn't make all that much sense. Grim still can't see it on the dedicated server or locally. Snacks can, and for some arbitrary reason i can as well now. problem appears to have mysteriously disappeared.

    Snacks suggested it was potentially related to my memory cache. But i can't desdinguish why it would work when it did and why it wouldn't, when it wouldn't.

    The fact that it happens to some people is bothersome. As it appears out of the blue for some individuals yet not others.
     
  4. Grim Tuesday

    aa Grim Tuesday

    Messages:
    1,257
    Positive Ratings:
    371
    Cross your fingers it doesnt happen to Valve!