Missing KeyValue's in non SmartEdit mode

Discussion in 'Mapping Questions & Discussion' started by Blinx, Jul 9, 2016.

  1. Blinx

    Blinx L69: Deviant Member

    Messages:
    69
    Positive Ratings:
    39
    To provide context as to why this maybe important, what I'm trying to do is change the filter of a certain trigger area using IO, and so far it's not worked, the area remains filterless.

    These images show a trigger_multiple with smartedit mode toggled on/off, and as you can see, certain Key Value's disappear, why is this? Is it just a bug? Why this bothers me is that Filter Name is one of the Key Value's that disappears, and the Filter Name is what I'm trying to alter using IO, so it makes me wonder, is Hammer trying to prevent the alteration of filters post compile?




    This shows how I'm trying to change the trigger areas filter



    I'm probably over complicating this as usual but maybe some IO wiz can help with this.
     
  2. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    You could just have two triggers, both with different filters, have one start disabled and one start enabled, then disable one and enable one when you want to switch filters.
     
  3. Blinx

    Blinx L69: Deviant Member

    Messages:
    69
    Positive Ratings:
    39
    What I'm trying to do is unfortunately a little bit more complicated, it's basically a condition gambling system with 6 different outcomes, where I randomize a trigger_tf_add_player_condition's filter.
     
  4. Hyperion

    aa Hyperion L16: Grid Member

    Messages:
    810
    Positive Ratings:
    617
    One complicated thing you can do is to open .vmf with text editor and find and edit your entity there
     
  5. Izotope

    aa Izotope Never releases maps

    Messages:
    609
    Positive Ratings:
    571
    Try giving your volume a filter, see if this allows changing it.
    It also won't disappear once it's set.

    EDIT:
    I noticed you use !caller, this is unfortunately broken for most things and is most likely the cause as to why nothing happens.
     
    • Thanks Thanks x 1
  6. Blinx

    Blinx L69: Deviant Member

    Messages:
    69
    Positive Ratings:
    39
    Well that sucks, had that worked this would have come together quite nicely. Tried all the other suggestions that didn't seem to fix it unfortunately.

    Thanks for the help, time to look for an alternative.
     
  7. Blinx

    Blinx L69: Deviant Member

    Messages:
    69
    Positive Ratings:
    39
    So I did some testing to find out what exactly entities consider the "caller" in an I/O chain and as it turns out, caller seems to work identically to self, which is sad because !caller seems to be a really powerful targeting mechanism, if it worked...
     
  8. henke37

    aa henke37

    Messages:
    1,879
    Positive Ratings:
    442
    SmartEdit shows the "missing" keyvalues because the FGD tells it that they are there. Without the FGD the editor can only show what's currently there. So if you haven't set a value yet, then it can't show it.
     
  9. Blinx

    Blinx L69: Deviant Member

    Messages:
    69
    Positive Ratings:
    39
    Izotope cleared that up thanks, I was curious if that was even a problem since I couldn't figure out where else to put the blame but it comes down to !caller being broken.