Map wont work on server

Discussion in 'Mapping Questions & Discussion' started by Ramaraunt, Mar 20, 2016.

  1. Ramaraunt

    Ramaraunt L1: Registered

    Messages:
    8
    Positive Ratings:
    1
    Hey all, I made a custom map for my tf2 server: Camelot Trade. Problem is, the map wont work. For some reason, it wont download to clients through my fastdl. I tried a different map, and it works perfectly fine. So the issue at hand, I have finally narrowed down, is within the map itself. The only question is: what is the issue? The map looks fine to me, but I am not very experienced with hammer. Here is a link to download my map. Tell me whats wrong with it.

    BSP:
    https://drive.google.com/file/d/0B_rNU8P3lqBqMDJUR0VuMGwyY28/view?usp=sharing

    VMX:
    https://drive.google.com/file/d/0B_rNU8P3lqBqMDJUR0VuMGwyY28/view?usp=sharing
     
  2. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    998
    Positive Ratings:
    1,135
    If your server is running Linux, the capital letters in your bsp filename might be causing the problem. When you rename the map, be sure to rename the vmf first and then recompile, not just rename the bsp.
     
    • Useful Useful x 1
  3. Ramaraunt

    Ramaraunt L1: Registered

    Messages:
    8
    Positive Ratings:
    1
    Aye when I ran it, it had lowercase. Thanks for trying to help though.

    EDIT wait the vmf bit, i didn't do that... I'll try.
     
  4. Ramaraunt

    Ramaraunt L1: Registered

    Messages:
    8
    Positive Ratings:
    1
    Well, after I changed the map name, some weird issues started happening. I have water in the center of my map, and it renders like there is a leak. But when I load point file, there is none...

    Compile Log:
    http://pastebin.com/0TXBd5K1
     
  5. Nicky

    aa Nicky Rotten Tops

    Messages:
    907
    Positive Ratings:
    1,664
    Did you run VIS on fast or something? I'm looking at your compile log and I don't see the regular VIS section.

    Edit: I checked again, and I am correct. You compile log says:
    Code:
    No vis information, direct lighting only.
    Not running VIS can cause lots of issues with your map, so just run it on normal when doing tests.
     
    • Funny Funny x 1
    • Useful Useful x 1
  6. Ramaraunt

    Ramaraunt L1: Registered

    Messages:
    8
    Positive Ratings:
    1
    /fp your right
     
    • Like Like x 1
  7. Ramaraunt

    Ramaraunt L1: Registered

    Messages:
    8
    Positive Ratings:
    1
    Thanks for the help, this was annoying but its finally fixed.
    You can see my map in action on my server at
    158.69.123.8:9025

    Its still a bit buggy, but its pretty fun.