Map won't fully compile...

Discussion in 'Mapping Questions & Discussion' started by Jazz, Mar 21, 2008.

  1. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    Hey, I've got another problem... Whenever I try to compile my map, it stops compiling after 10-15 seconds. I checked the map AND INTERLOPERS for problems and everything seems to be ok. But when I run the map, several brushes are missing, lights are all messed up, etc.

    Here is my compile log in case you need it.

     
  2. MrAlBobo

    MrAlBobo L13: Stunning Member

    Messages:
    1,059
    Positive Ratings:
    219
    open tf2 and see if it needs to be updated, that happened to me once...and after the update the map ran just fine

    and just saying...it appears that the compile does finish, id recommend a 2nd opinion though, im still a newb at this :D
     
  3. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,745
    Thats your problem. go into hammer find the offending overlay (may not actually cover that many brushes) and delete it compile it again to make sure it works then try adding it back in smaller or in different location.
    Its so nice it even gives you the co-ords of the overlay!
    Note: If interlopers comes back negative then READ THE LOG YOURSELF The error usuall falls right out.
    Edit: just gotta keep hammering in this compile log checking business, the more we say it, the more people will pick up on it. I stress it every time I say it, not because i'm having a go at you, but because its important. people need to become independant, one of the simplest ways of doing that with mapping is checking out errors yourself, whilst using interlopers isnt strictly independant its damn close to it, then if your best friend for finding errors fails read the log yourself, it only takes a moment.
     
    Last edited: Mar 21, 2008
  4. trainRiderJ

    trainRiderJ L5: Dapper Member

    Messages:
    203
    Positive Ratings:
    31
    While we're on the subject of checking your own compile logs, what does this mean?

    Also, is there a directory or glossary of common (and uncommon) compiler errors and warnings?
     
  5. Aarchane

    Aarchane L1: Registered

    Messages:
    5
    Positive Ratings:
    0
  6. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
  7. phatal

    phatal L6: Sharp Member

    Messages:
    259
    Positive Ratings:
    21
    This has happened so many times for me as well. The first few times I was clueless.
     
  8. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    Yea, you were right about the overlay thing. Thanks.
     
  9. MrAlBobo

    MrAlBobo L13: Stunning Member

    Messages:
    1,059
    Positive Ratings:
    219
    yeah...it took me quite awhile to figure that one out, but not as long as it took me to notice that my light_env slipped out of the map when I shrunk the skybox <_<

    and I can't help but notice your sig, i happen to have the same processor. What temp is yours running at? Ive only overclocked it to 3.2 before it got too hot for my liking
     
  10. phatal

    phatal L6: Sharp Member

    Messages:
    259
    Positive Ratings:
    21
    When I'm running her at 3.6 I idle at 39-40C, but my cores stay around 35-38C. After compiling my level with hdr -slow (~5 minutes to complete) she can get up to 60C cores 52-56. I live in GA so it gets really hot. :D When it was colder I'd stay around 33 idle and 50 under load.

    What heatsink do you have and what vcore do you run @ 3.2. You probably should only need 1.31. I think I have mine @ 1.39 or 1.41.
     
  11. MrAlBobo

    MrAlBobo L13: Stunning Member

    Messages:
    1,059
    Positive Ratings:
    219
    hmm...mine is about the same when idle, but it only gets up to about 46 at full load (it was running room temp before i oced it)
    my heatsink is some copper setup, no idea what the name is, and i used some silver based thermal compound

    and i have absolutely no idea what vcore is...ill take a look on google and get back to you XD

    ahh...just checked, and i never actually did that, I only went as far as increasing the frequency of the fsb