Map stuck in Full Bright

Discussion in 'Mapping Questions & Discussion' started by Doc Bananas, Aug 2, 2020.

  1. Doc Bananas

    Doc Bananas L1: Registered

    Messages:
    11
    Positive Ratings:
    1
    Hi folks. My map is stuck in full bright. I've given it a skybow and an enviroment light but nothing happens. Anyone know what to do?
     
  2. VasyaTheWizard

    VasyaTheWizard L3: Member

    Messages:
    100
    Positive Ratings:
    56
    Check if you perhaps have mat_fullbright on?
     
  3. Doc Bananas

    Doc Bananas L1: Registered

    Messages:
    11
    Positive Ratings:
    1
    How do I check that?
     
  4. Pinsplash

    Pinsplash bad bad bad

    Messages:
    133
    Positive Ratings:
    63
  5. Soilbleed

    Soilbleed L2: Junior Member

    Messages:
    59
    Positive Ratings:
    127
    I get this occasionally, and find building cubemaps / restarting TF2 tends to fix it:

    To build your cubemaps, open the console with TF2 open and fire in the following commands one after the after:

    -mat_specular 0
    -map <mapname>(Load your map)
    -buildcubemaps
    -mat_specular 1
    -disconnect
    -map <mapname>(Load a different level; clears texture cache)
    -map <mapname>(Load you map again)

    If its still in full bright after reloading your map, try restarting TF2 and loading the map again.
     
    • Thanks Thanks x 1
  6. Werewolf

    Werewolf Probably not a real Werewolf

    Messages:
    869
    Positive Ratings:
    277
    I like how no one has suggested checking is VRAD has run properly.

    Post your compile log please, ideally in [.spoiler] tags.
     
  7. Doc Bananas

    Doc Bananas L1: Registered

    Messages:
    11
    Positive Ratings:
    1
    Where do I post the compile log?
     
  8. eighntes

    eighntes L1: Registered

    Messages:
    31
    Positive Ratings:
    26
    • Thanks Thanks x 1
  9. Doc Bananas

    Doc Bananas L1: Registered

    Messages:
    11
    Positive Ratings:
    1
    Thanks for all the help. I've managed to get it working.
     
    • Like Like x 1
  10. H1gh0nSt34m

    H1gh0nSt34m L1: Registered

    Messages:
    1
    Positive Ratings:
    0
    How did you get it working? I'm having the same problem
     
  11. Doc Bananas

    Doc Bananas L1: Registered

    Messages:
    11
    Positive Ratings:
    1
    Soilbleed's tip helped the most I simply restarted tf2
     
  12. Xbmann

    aa Xbmann

    Messages:
    8
    Positive Ratings:
    3
    For future reference, many different things can cause the map to appear in fullbright:
    • If you load your map after playing a different map with mat_fullbright turned on, the setting will carry over and you will need to turn on sv_cheats and change mat_fullbright to properly enable lighting.
    • If vrad is failing to run then there will be no lighting information in the map and it will be stuck on fullbright, check the compile log and make sure it is running properly.
    • If you are compiling with HDR only then people with hdr off ingame will be stuck in fullbright. Compile with the -both vrad parameter to run both HDR and LDR.
     
    • Like Like x 1
    Last edited: Aug 7, 2020 at 12:20 AM
  13. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,752
    Positive Ratings:
    357
    you don't have to do the whole cube maps thing

    sv_cheats 1 (turn on 0 to turn off)
    mat_fullbright 0

    if you have compiled correctly you will see the properly lit version appear. What also hasn't been mentioned is something like this

    you compile have a leak and run map - you see no properly lit up map < due to the leak
    you fix the leak compile and run map - you see no properly lit up map < this time though the lighting cache is still in the memory

    if you do the two commands above - it loads the actual lighting and you'll see it go from the contrasty thing on screen to the properly lit item.