map problem. strange lighting being black at certain angles

Discussion in 'Mapping Questions & Discussion' started by poopster101, Feb 8, 2008.

  1. poopster101

    poopster101 L4: Comfortable Member

    Messages:
    155
    Positive Ratings:
    5
    Last edited: Feb 8, 2008
  2. Tokit

    Tokit L1: Registered

    Messages:
    26
    Positive Ratings:
    0
    Are you using a model texture on the bridge? The purple checkerboard on your roof is because you do not have a cubemap in your map yet.
     
  3. dirtyminuth

    dirtyminuth L5: Dapper Member

    Messages:
    221
    Positive Ratings:
    14
    1. Player position-dependent lighting usually means you're using a texture from a models/props subdirectory. What are the names of the textures you're using on the bridge?

    2. Tokit is right, you need to place at least one env_cubemap in your map and then, in game, type "buildcubemaps" in the console.
     
  4. poopster101

    poopster101 L4: Comfortable Member

    Messages:
    155
    Positive Ratings:
    5
    idk know why the checkerboard was there cuz it wasnt before and the next time i ran the map it wasnt
    but i might be using a model texture
    im use teh wood beam one
    i will change it and see if that fixes it
    thanks
     
  5. poopster101

    poopster101 L4: Comfortable Member

    Messages:
    155
    Positive Ratings:
    5
    yea it fixed it. thanks a bunch to both of you :D
     
  6. Haas

    Haas Guest

    Positive Ratings:
    0
  7. poopster101

    poopster101 L4: Comfortable Member

    Messages:
    155
    Positive Ratings:
    5
  8. MacNetron

    MacNetron L5: Dapper Member

    Messages:
    203
    Positive Ratings:
    47
    ^^
    He meant to say:
    Yeah, I saw it already when browsing your magnificent site. Thanks for the tip anyway ;)
     
  9. Nosher

    Nosher L4: Comfortable Member

    Messages:
    184
    Positive Ratings:
    20
    Have I missed something here - I am getting the same black shadow showing on the wooden platforms - I already have a env_cubemap placed over some water in the same room - should I have a env_bubemap for each time I see the black thingy??

    Cheers

    Nosh
     
  10. fartron

    fartron L1: Registered

    Messages:
    45
    Positive Ratings:
    11
    You missed number 1 there. You're probably using model textures. All the model textures have world equivalents, you'll want to replace them.
     
  11. Nosher

    Nosher L4: Comfortable Member

    Messages:
    184
    Positive Ratings:
    20
    Apologies - I don't understand what I have done wrong (not a seasoned mapper, you know!) is there a quick way of replacing them (whatever they are!)

    Thanks in advance
    Nosh.
     
  12. fartron

    fartron L1: Registered

    Messages:
    45
    Positive Ratings:
    11
    You're likely using textures that are in the models/ directory. Check the texture names in hammer, and if they are you'll have to find their equivalents. For example, models/props_mining/wall020 will give you the black lighting errors, while wood/wall020 will not, although it looks the same in hammer. The texture application tool (shift+a) has a Replace... button that will bring up a dialog.
     
  13. Nosher

    Nosher L4: Comfortable Member

    Messages:
    184
    Positive Ratings:
    20
    thanks for the quick response - really appreciated...

    Will try and sort....

    Nosh.