Map not updating

Discussion in 'Mapping Questions & Discussion' started by Chlorine72, Feb 16, 2019.

  1. Chlorine72

    Chlorine72 L1: Registered

    Messages:
    3
    Positive Ratings:
    1
    I'm making a complete map for the first time. But when I complie map. it doesn't update.

    I tried check for problems and fixed all, and there's probably no leaks (I cannot create point file, but at least every prop and displacements are in), I refreshed source SDK Files. And still it doesn't update.

    Here's the compile log: (bsp normal, vis and rad both fast)

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore.vmf"

    Valve Software - vbsp.exe (Aug 2 2018)
    4 threads
    materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore.vmf
    Trying to create a non-quad displacement! (entity 0, brush 343)


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -fast "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore"

    Valve Software - vvis.exe (Aug 2 2018)
    fastvis = true
    4 threads
    reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore.bsp
    reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore.prt
    LoadPortals: couldn't read c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore.prt


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -noextra "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore"

    Valve Software - vrad.exe SSE (Jul 18 2018)

    Valve Radiosity Simulator
    4 threads
    [Reading texlights from 'lights.rad']
    unknown light specifier type - lights

    [56 texlights parsed from 'lights.rad']

    Loading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore.bsp
    Setting up ray-trace acceleration structure... Done (0.39 seconds)
    3803 faces
    4 degenerate faces
    2250466 square feet [324067136.00 square inches]
    36 Displacements
    497912 Square Feet [71699408.00 Square Inches]
    3799 patches before subdivision
    84891 patches after subdivision
    sun extent from map=0.000000
    light has _fifty_percent_distance of 500.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 500.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 500.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 500.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 500.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 500.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 500.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 500.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 300.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 300.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 300.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 300.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 300.000000 but _zero_percent_distance of 0.000000
    light has _fifty_percent_distance of 300.000000 but _zero_percent_distance of 0.000000
    16 direct lights
    BuildFacelights: 0...1...2...3...4...5...6...7...8...9...10 (4)
    BuildVisLeafs: 0...1...2...3...4...5...6...7...8...9...10 (9)
    transfers 6882094, max 1163
    transfer lists: 52.5 megs
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #1 added RGB(229876, 140999, 89105)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #2 added RGB(26668, 11413, 5850)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #3 added RGB(3929, 1184, 488)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #4 added RGB(649, 138, 45)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #5 added RGB(116, 17, 4)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #6 added RGB(24, 2, 0)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #7 added RGB(5, 0, 0)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #8 added RGB(1, 0, 0)
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #9 added RGB(0, 0, 0)
    Build Patch/Sample Hash Table(s).....Done<0.0245 sec>
    FinalLightFace: 0...1...2...3...4...5...6...7...8...9...10 (3)
    FinalLightFace Done
    0 of 0 (0% of) surface lights went in leaf ambient cubes.
    ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (4)
    Writing leaf ambient...done
    Ready to Finish

    Object names Objects/Maxobjs Memory / Maxmem Fullness
    ------------ --------------- --------------- --------
    models 17/1024 816/49152 ( 1.7%)
    brushes 530/8192 6360/98304 ( 6.5%)
    brushsides 3484/65536 27872/524288 ( 5.3%)
    planes 1938/65536 38760/1310720 ( 3.0%)
    vertexes 5806/65536 69672/786432 ( 8.9%)
    nodes 2305/65536 73760/2097152 ( 3.5%)
    texinfos 817/12288 58824/884736 ( 6.6%)
    texdata 18/2048 576/65536 ( 0.9%)
    dispinfos 36/0 6336/0 ( 0.0%)
    disp_verts 2916/0 58320/0 ( 0.0%)
    disp_tris 4608/0 9216/0 ( 0.0%)
    disp_lmsamples 587484/0 587484/0 ( 0.0%)
    faces 3803/65536 212968/3670016 ( 5.8%)
    hdr faces 0/65536 0/3670016 ( 0.0%)
    origfaces 1782/65536 99792/3670016 ( 2.7%)
    leaves 2323/65536 74336/2097152 ( 3.5%)
    leaffaces 4284/65536 8568/131072 ( 6.5%)
    leafbrushes 1675/65536 3350/131072 ( 2.6%)
    areas 2/256 16/2048 ( 0.8%)
    surfedges 25626/512000 102504/2048000 ( 5.0%)
    edges 14050/256000 56200/1024000 ( 5.5%)
    LDR worldlights 16/8192 1408/720896 ( 0.2%)
    HDR worldlights 0/8192 0/720896 ( 0.0%)
    leafwaterdata 0/32768 0/393216 ( 0.0%)
    waterstrips 385/32768 3850/327680 ( 1.2%)
    waterverts 0/65536 0/786432 ( 0.0%)
    waterindices 6168/65536 12336/131072 ( 9.4%)
    cubemapsamples 2/1024 32/16384 ( 0.2%)
    overlays 1/512 352/180224 ( 0.2%)
    LDR lightdata [variable] 5945768/0 ( 0.0%)
    HDR lightdata [variable] 0/0 ( 0.0%)
    visdata [variable] 298807/16777216 ( 1.8%)
    entdata [variable] 45183/393216 (11.5%)
    LDR ambient table 2323/65536 9292/262144 ( 3.5%)
    HDR ambient table 2323/65536 9292/262144 ( 3.5%)
    LDR leaf ambient 11683/65536 327124/1835008 (17.8%)
    HDR leaf ambient 2323/65536 65044/1835008 ( 3.5%)
    occluders 0/0 0/0 ( 0.0%)
    occluder polygons 0/0 0/0 ( 0.0%)
    occluder vert ind 0/0 0/0 ( 0.0%)
    detail props [variable] 1/12 ( 8.3%)
    static props [variable] 1/5992 ( 0.0%)
    pakfile [variable] 723/0 ( 0.0%)
    physics [variable] 196019/4194304 ( 4.7%)
    physics terrain [variable] 3296/1048576 ( 0.3%)

    Level flags = 0

    Total triangle count: 10883
    Writing c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore.bsp
    20 seconds elapsed

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\mvm_encore.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\mvm_encore.bsp"


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\hl2.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" +map "mvm_encore" -steam
     
  2. Simon.R.K

    Simon.R.K L1: Registered

    Messages:
    27
    Positive Ratings:
    4
    Have you tried https://www.interlopers.net/errors/?page=errors&params=
    Because on this site you can post your log and it will tell you this:

    trying to create a non-quad displacement!
    Description:
    Displacements can only have four sides, no more, no less.

    Solution:
    Find your displacement (you'll have to check each one in your level) and recreate it so it has four sides again. You may need to be creative with some vertex manipulation for some shapes you want to create with displacements.

    See also:
    Finding the unfindable


    This error will cause your map to fail compiling completely
     
    • Agree Agree x 3
  3. Da Spud Lord

    aa Da Spud Lord Occasionally I make maps

    Messages:
    1,291
    Positive Ratings:
    858
    Actually, it doesn't even look like you'll need to do that. Just find this brush number by going to "View" > "Go to Brush Number..."
    Then destroy that displacement and make it 4-sided.
     
  4. Chlorine72

    Chlorine72 L1: Registered

    Messages:
    3
    Positive Ratings:
    1
    "Brush id does not exist". Anyways I fixed some errors and almost checked every displacement to have four sides. But it still says:

    Trying to create a non-quad displacement! (entity 0, brush 0)

    Plus, this weird triangle error exists at the axis of the map. How do I fix this?
    https://imgur.com/lBEFLUa
     
  5. ics

    aa ics http://ics-base.net

    Messages:
    814
    Positive Ratings:
    513
    You have iinvalid brush like others tried to say. Press and hold alt and press p for error dialog. Fix errors like invalid brush. Note that pressing fix might not do it the way you want.
     
    • Agree Agree x 1
  6. Chlorine72

    Chlorine72 L1: Registered

    Messages:
    3
    Positive Ratings:
    1
    Okay. Turns out a triangular displacement was hiding invisible. I box selected all displacements and de-selected all quad displacements to find it...
    Thanks all.
     
    • Like Like x 1