1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

Map not updating

Discussion in 'Mapping Questions & Discussion' started by Moonrat, Jul 30, 2014.

  1. Moonrat

    aa Moonrat The end of an era

    Messages:
    898
    Positive Ratings:
    533
    I seem to have found a problem. I update my map, Compile it, then when I play it, I don't see those changes. I don't really now what's causing it though..... :O
     
  2. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    5,464
    You probably have a VBSP error that is popping up, like an Invalid solid or a displacement thats an entity.

    Hit alt+p and that'll tell you if you have any issues with your solids.
    everything else? just copy the compile log into here. It'll check everything for you and tell you anything that might be wrong. If that still doesn't help, bug us again (or bug us if you questions!)
     
  3. Coolz

    Coolz L2: Junior Member

    Messages:
    72
    Positive Ratings:
    18
    Just rename the map every time you want to compile it, (for example, from compile_1 to compile_2 in save as) that fixes it up for some reason. I had that problem during the 72hr contest and the last hours of it, too. annoying as hell, but luckily I found a way to fix it quickly.
    Hopefully this helps.
     
    Last edited: Jul 30, 2014
  4. Moonrat

    aa Moonrat The end of an era

    Messages:
    898
    Positive Ratings:
    533
    Thanks, That is pretty useful!
     
  5. Moonrat

    aa Moonrat The end of an era

    Messages:
    898
    Positive Ratings:
    533
    Ugh, I'm still having the problem, I tried the renaming and I put the log through that error checker. The error checker seems to keep telling me that I have a leak in the map or my sky_camera is stuck in a solid brush. I checked, and there are no leaks, and the sky_camera is not in any ground
     
  6. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    5,464
    Then you have a bsp error. I assume when you checked for leaks you compiled the map, went to load the maps point file, then recompiled and checked again? Once you plug a leak you have to recompile before you check for another leak.

    Also, might you accidently have 2 sky cameras, one being in the ground in the main map? Check the entity report to be sure.

    This might all sound really silly, I just want to make sure to cover all the bases, since I don't know what you do and don't know.
     
  7. Moonrat

    aa Moonrat The end of an era

    Messages:
    898
    Positive Ratings:
    533
    I did the entity report, and turns out there was a sky_camera under Red's base for no reason. Thanks!
     
    • Thanks Thanks x 1
  8. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    5,464
    Awesome, glad to hear it was fixed!