Map not packing with custom content

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

Sparkie11

L1: Registered
Aug 17, 2016
27
I've packed, and re packed my map but the custom content just won't show up in game, I'm using VIDE to pack the custom content, and the file size indicates it's packed but when my brother boots up the map it's errors and missing textures, any help would be greatly appreciated
 
Mar 23, 2013
1,015
Did you add the custom content manually or automaticly? If manually, perhaps you specified the paths incorrectly?
 

Sparkie11

L1: Registered
Aug 17, 2016
27
I've narrowed it down to the fact that the meshes aren't packing with everything else
 

HashtagMC

L1: Registered
Dec 17, 2016
15
I don't like VIDE's auto mode, so I usually pack content manually, and I've never had a problem with it. Have you tried packing it manually? I usually follow TopHATTwaffle's tutorial (no idea whether I'm allowed to link to that, you can just google "tophattwaffle vide", should be the first link).

If everything else fails, you could always try to go the "hard way" and use Valve's bspzip. It's tedious, but if the problem lies within VIDE, bspzip should do.
 

MOCOLONI

L6: Sharp Member
Dec 16, 2014
373
Contents' locations should start with "/materials", "/models", "/sounds" and such (aka removing everything until "/tf", leaving the next subfolders in the directories).
 
Mar 23, 2013
1,015
(no idea whether I'm allowed to link to that

...why exactly should that be forbidden? o_O

http://www.tophattwaffle.com/packing-custom-content-using-vide-in-steampipe/

There is only one thing that he didnt fogure out very well. At step 4 he recommends clicking "cancel" isntead of "OK" which then requires you to type the path manually.

However I always click "OK", VIDE unfortunately puts the entire file path in there, example:
"C/programms/Steam/steamApps/common/Team Fortress 2/tf/materials/my_custom_texture/"
But it's easier to just cut of everything at the start yourself instead of typing it out yourself. So select "OK" and then just delete the path until /tf/ so you have:
"/materials/my_custom_texture/"

as MOCOLONI correctly pointed out you probably need to keep the "/" before the first folder.
 
Last edited: