Map not compiling new changes?

Discussion in 'Mapping Questions & Discussion' started by Kariko, Jul 6, 2013.

  1. Kariko

    Kariko L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Hello all,

    I've started to make a TF2 map. This will be my first TF2 map, though I have worked with the Portal 2 version of Hammer a little bit so I know some very simple things. But the issue I am getting now is that I have added some additional prop_static stairs to my map (I have some already somewhere else, I just made some more) and when I compile, the changes don't apply when I load it up in TF2. There are no leaks in the map and I can't figure out what the problem is. I've even tried drastic changes that would be obvious when loaded like removing an entire wall, but the change still doesn't load. It's stuck in a previous version that didn't have these stair models. Does anyone have any idea what could be going on?

    Thanks for any information in advance.
     
  2. henke37

    aa henke37

    Messages:
    1,890
    Positive Ratings:
    443
    Check if the build completed successfully, it may simply have failed and is running on the old version.
     
  3. Kariko

    Kariko L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    How do I do that? I also found this in the log, not sure if it's related.

     
  4. duppy

    duppy L1: Registered

    Messages:
    35
    Positive Ratings:
    8
    I've recently had that happen to me too. Not sure if it was a dumb mistake I made somewhere along the way or what. For a quick fix I usually end up doing a "save as" to change the file name and then recompile and it's fine.

    I half-attempted to find the problem, and one thing I found that may have been the cause was that somehow my map (BSP) got copied to "tf/maps/" despite the fact that I configured Hammer to use "tf/download/maps/". I think it might have been after I ran buildcubemaps, but I haven't tested it again to see if that was the what screwed it up. To fix it, I just found all copies my BSP file, delete 'em and recompiled.

    It'd be interesting to know if other people had this problem, but I have a feeling it's just a mistake on my part ;)
     
  5. Kariko

    Kariko L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Agh, I tried saving as a different name (just added a 1 to the end) and now it says it's failing to find the file when I try to compile it.

     
    Last edited: Jul 6, 2013
  6. Blade x64

    aa Blade x64 Logical insanity

    Messages:
    203
    Positive Ratings:
    463
    The inability to find the file usually means that there was a fatal error in the compile. It wasn't giving the error before you renamed it because it was using the bsp file from a previous successful compile. Paste your entire compile log into http://www.interlopers.net/errors and read about the problems it finds.
     
    • Thanks Thanks x 1
  7. Kariko

    Kariko L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Thank you so much! My newbiness to mapping was the issue, I had textured a player clip brush to also have a fence texture on one side, and I used the site you sent and that was the issue. I am such a moron. Thanks again!