Buy Elder Scrolls Online: Greymoor for PC at Green Man Gaming

Map looks really washed out with HDR on ingame. [SOLVED]

Discussion in 'Mapping Questions & Discussion' started by ThirdEye, Jul 11, 2019.

  1. ThirdEye

    ThirdEye L1: Registered

    Messages:
    25
    Positive Ratings:
    1
    The whole map looks too bright, too white. How do I fix this in hammer?
     
  2. Dr. Orange

    Dr. Orange L6: Sharp Member

    Messages:
    382
    Positive Ratings:
    289
    Create an env_tonemap_controller in Hammer, and set its name to something like "tonemap". Then compile the map with HDR. Once you have loaded your map in-game, open up the developer console and type in "ent_fire tonemap <input> <value>". For <input>, use SetAutoExposureMax, SetAutoExposureMin, SetBloomScale and SetToneMapRate, and for <value>, use whatever number you want to.

    Experiment with these settings using different values until you get the result you want. There's a lot of trial and error here, and you'll most likely not get a good looking result from the start.

    Next, go back to Hammer and add a logic_auto entity that fires the same inputs to the tonemap controller you did earlier with the values you found gave the best result.

    This should help you improve your HDR lighting.
     
    • Thanks Thanks x 1
  3. henke37

    aa henke37

    Messages:
    2,028
    Positive Ratings:
    488
    And of course, don't forget that you get to pick separate HDR settings for each light entity.
     
  4. iiboharz

    aa iiboharz eternally tired

    Messages:
    776
    Positive Ratings:
    1,124
    Yeah but like, who even uses those honestly
     
  5. ThirdEye

    ThirdEye L1: Registered

    Messages:
    25
    Positive Ratings:
    1
    I adjusted the bloom amount and compiled it and it works. Thank you.
     
Buy Elder Scrolls Online: Greymoor for PC at Green Man Gaming