Map crashing while loading in-game

Discussion in 'Mapping Questions & Discussion' started by Zidone, Oct 16, 2009.

  1. Zidone

    Zidone L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    I've been working on a map for a few weeks, and it compiles fine and well on full settings, without any leaks. However, when I load the map to test it, TF2 minimizes and crashes before getting to the "Initializing resources" part of the loading screen.

    Check for problems shows nothing, and older (and I mean old, unfortunately I didn't compile very often) versions of the map work fine.

    I doubt it's something caused by VVIS or VRAD, because compiling with both of those disabled or on fast does not change the fact that it crashes. The compile log checker shows nothing when I compile with VVIS and VRAD disabled, and only zero area child patches when I run a full compile.

    The following is the log from my last full compile, which I started while writing this post:

    Notes: My map uses custom materials and music, and has a 3d skybox.

    Also, this is my first post. Cool.
     
  2. Dr. ROCKZO

    Dr. ROCKZO L8: Fancy Shmancy Member

    Messages:
    580
    Positive Ratings:
    159
    Well, you have that Zero Area Patch, which shouldn't be causing much of a problem, but it is there.

    Interlopers says:

    Description:
    A solid in your level has a face with no area. My guess is that vrad.exe is trying to create a lightmap for a face that doesn't exist. Maybe you have an invalid brush?

    Solution:
    First check Hammers problemchecker (alt+p). If that doesn't solve your problems, you can either ignore the error, or try to find it anyway using cordon tools. You would be looking for brushes which might be too complex. I wouldn't recommend the second option.
     
  3. Zidone

    Zidone L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    The problem checker doesn't return anything, and not running VRAD eliminates the compile error but still causes the map to crash.
     
  4. Dr. ROCKZO

    Dr. ROCKZO L8: Fancy Shmancy Member

    Messages:
    580
    Positive Ratings:
    159
    Then, unless your map is called pa test4 (with a space and not an underscore) I'd say it's something to do with your custom content, try eliminating it one at a time and seeing if that stops the error.
     
  5. Zidone

    Zidone L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    It seems the crashes were caused by my misuse of cart dispensers; removing them fixed the problem.