make_triangles:calc_triangle_representation: Cannot convert

Discussion in 'Mapping Questions & Discussion' started by Pocket, Jan 11, 2014.

  1. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    I've been getting this lately in my Fort Frolic map when I try to compile. There are four of them, and each one is preceded by three or four sets of coordinates. But when I try to go to those coordinates, there's nothing there! I've even tried copypasting everything into a new map to see if that would do it, but no dice. What the hell is going on here?
     
  2. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    One time a model in my map caused this error. The model was three red big rockets. (even an offical tf2 prop)
    But I think a bad displacment can cause this as well. Just compile with RAD only and with the cordon tool you select single parts of the map until you found the cause of the error.
     
  3. Garuda112

    Garuda112 L1: Registered

    Messages:
    38
    Positive Ratings:
    27
    I've had that crop up with some assorted props while I worked on tminus. In particular, it involved the train missile prop (three missiles strapped together on a bed). The error was apparently tied to the prop as it would go away when I removed them. The coordinates had nothing to do with the issue, apparently.

    Unfortunately, there was no way to tell what prop was causing the issue except by trial and error. That said, the error caused no obvious issues. So, it might not be something to worry about. Some maps have such props (like Dustbowl), so again it might not be affecting anything.

    Wish I could provide more insight, but I hope that is a way to diagnose the problem.


    *edit* Lampenpam beat me to it. Still, it looks to be the same issue.
    ~G
     
  4. Crash

    aa Crash func_nerd

    Messages:
    3,184
    Positive Ratings:
    4,883
  5. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    Well, it's not a prop; I tried compiling with all of them off. And it's not a displacement because I don't have any of those.

    Guess I'll just ignore it for now, then. My concern is that it's something whose origin lingered after I thought I removed it, and now can't be removed. It's not likely to be, is it?
     
  6. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,869
    Positive Ratings:
    4,896
    As far as I understand this error can largely be ignored. I've never had an issue with it.
     
  7. XEnderFaceX

    XEnderFaceX L4: Comfortable Member

    Messages:
    169
    Positive Ratings:
    48
    i know this thread was in 2014, but in case you have this problem again, you just have to prop_dynamic whatever prop is causing it, atleast that worked for me.
     
  8. Diva Dan

    aa Diva Dan hello!

    Messages:
    850
    Positive Ratings:
    1,443
    also since this thread is bumped, if you use the merc park helicopter in your map, you’ll get this error: just an FYI
     
    • Funny Funny x 1
  9. Dutch_

    Dutch_ L1: Registered

    Messages:
    1
    Positive Ratings:
    0
    Hi! I started to have this same problem and it actually made my map unplayable, the game jsut stops loading it and quits to the main menu.
    I have teh rocekts prop on my map but it havent made an error before
    The props i have added since the last playable state were:
    2 different barrels (never caused error for me before)
    1 stair from the tf2 mapping addon thing Crash points to
    1 wooden fence
    I used 1 texture that is basically just black (overlay/black_gradient)
    IF anybody can help I would be really happy
     
  10. Unregistered HyperCam 2

    Unregistered HyperCam 2 L3: Member

    Messages:
    102
    Positive Ratings:
    4
    since the thread has been bumped again, I am having this problem as well even after removing all prop_dynamics from my map, and not using any custom models.
    No displacements or the helicopter model either.