Make areas darker?

Discussion in 'Mapping Questions & Discussion' started by fbi.bmw.ultra.car, May 14, 2019.

  1. fbi.bmw.ultra.car

    fbi.bmw.ultra.car L2: Junior Member

    Messages:
    52
    Positive Ratings:
    1
    Hello, is here any way to make parts of your map darker? Like dark forest you can wall through.
    I tried func_dustcloud but thats not working very well. :/
     
  2. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    853
    Positive Ratings:
    268
    Um..... less light entities? Lower their brightness settings? The 4th number in the 'color' setting controls brightness:
    Code:
     <red> <green> <blue> <brightness>
     
  3. Jeff Magnum

    Jeff Magnum L1: Registered

    Messages:
    20
    Positive Ratings:
    7
    the nodraw texture blocks light reaching whatever's behind it, but that may be too crude a solution. If you want realistic dark areas I'd suggest using a very dim light_environment and then extensively lighting wherever you don't want to be dark.
     
  4. fbi.bmw.ultra.car

    fbi.bmw.ultra.car L2: Junior Member

    Messages:
    52
    Positive Ratings:
    1
    I dont have any light entities there, idk if it will work with lowering brightness
     
  5. Narpas

    aa Narpas Failing at Scaling

    Messages:
    300
    Positive Ratings:
    286
    You can make light entities cast "dark" light by setting the colour values to black or something similar, if I'm not mistaken. You can also use the blocklight texture to block light, which will probably look more realistic
     
  6. fbi.bmw.ultra.car

    fbi.bmw.ultra.car L2: Junior Member

    Messages:
    52
    Positive Ratings:
    1
    is the texture nodraw or how is it called?
     
  7. Jeff Magnum

    Jeff Magnum L1: Registered

    Messages:
    20
    Positive Ratings:
    7
    The blocklight texture is probably better than nodraw since it's not solid, though both will block light
     
  8. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    853
    Positive Ratings:
    268
    If you don't have any light entities there and it's still too bright, then either your env_lighting is too bright or you don't have any lights whatsoever and what you're seeing is actually mat_fullbright.

    Can you confirm which this is?
     
    • Agree Agree x 2