Make an Invisible Button

Discussion in 'Mapping Questions & Discussion' started by 【EmNudge】, May 29, 2016.

  1. 【EmNudge】

    【EmNudge】 L4: Comfortable Member

    Messages:
    184
    Positive Ratings:
    38
    This is pretty simple and I have done it quite a few times before, so I don't know why I am struggling now.

    I want to make a func_button somewhere in my map that is invisible. It will be hidden right by a prop_static (partially inside) and upon hitting it will enable and disable a trigger_teleport to teleport you somewhere.

    I tried using a player clip and a nodraw brush with the func_button, but I could never get gunshots and melee hits to trigger it for some reason. When the brush was a player clip and positioned in a certain place, blast damage activated it though, but still no gun shots or melee hits.

    What am I doing wrong?
     
  2. Izotope

    aa Izotope Never releases maps

    Messages:
    626
    Positive Ratings:
    599
    Maybe your button was inside the prop's collision model, therefore blocking direct hits.
    Toggle the :cm: button to view prop collisions.

    A few more tips:
    :nodraw: your buttons and perhaps even set the Render Mode of the button to "Don't Render" (inside the properties).
    As for the flags and outputs, tick the "Use Activates", "Damage Activates" and the "Don't Move" flags,
    ignoring all movement properties, which in your case are not needed.
    Use the "OnPressed" outputs, not the "OnDamaged" outputs.
     
    • Agree Agree x 1
  3. Bogdy

    Bogdy L4: Comfortable Member

    Messages:
    187
    Positive Ratings:
    208
    Isn't that supposed to be the other way around for TF2?
     
  4. zahndah

    aa zahndah professional letter

    Messages:
    718
    Positive Ratings:
    627
    nope, because with 'damage activates' ticked the button receiving damage counts the same as +use, so people can use either (despite that fact that +use is not bound by default).
     
  5. 【EmNudge】

    【EmNudge】 L4: Comfortable Member

    Messages:
    184
    Positive Ratings:
    38
    thanks, but I actually did all that already. Not new to mapping entirely.

    The actual problem was much stupider. I accidentally erased all the outputs on the button. I put them back and it was all good.
     
  6. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,441
    Positive Ratings:
    1,196
    I'd recommend double checking such things before asking, but who of us can't be in such a situation.
     
  7. 【EmNudge】

    【EmNudge】 L4: Comfortable Member

    Messages:
    184
    Positive Ratings:
    38
    I just didn't think something as stupid as that would have been the problem. All I did was change texture, so it was probably some sort of bug.

    I was going to comment directly after my post, saying that I had fixed the problem, but I had internet problems and couldn't reconnect until the day after.