Low res logic entities?

Discussion in 'Mapping Questions & Discussion' started by s0da72, Aug 28, 2013.

  1. s0da72

    s0da72 L2: Junior Member

    Messages:
    74
    Positive Ratings:
    17
    I'm not sure how or when this changed but in the 3D view window logic entities show up fuzzy like they are low resolution or something.

    [​IMG]


    Is there an option to change this behavior?

    :confused:
     
  2. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    steamapps\common\team fortress 2\bin\dxsupport.cfg

    Search for "picmip" and locate Convar.mat_picmip under the 14 group and lower it to -1. (I am assuming you don't have an ancient video car with less than 256 MB of vram, in which case it would be group 12 or 13)
     
    • Thanks Thanks x 1
  3. Bombcartography

    Bombcartography L1: Registered

    Messages:
    25
    Positive Ratings:
    7
    Looks like the recent update caused this. I had to update TF2 to test a map I'm working on and when I came back to Hammer, everything was blurry. Not just the entities but also the textures and props.
     
  4. s0da72

    s0da72 L2: Junior Member

    Messages:
    74
    Positive Ratings:
    17
    My video cards is a couple of years old, hopefully that is not an issue. GTX 580 with 1.5GB memory.


    very strange, it doesn't affect anything when building the map.
     
  5. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,217
    Looks like most textures were affected by this. Oddly enough, color_correction's icon was not.

    Funny that mat_picmip 0, the default setting, is causing this. In the game itself it would be the equivalent of "High" texture quality, would it not?
     
  6. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    As far as I know 0 is still not un-mipmaped, not sure what they equate to in the menu. The CC icon not being affected is because that VTF has no mipmips (should be how all icons/hud/vgui textures are).
     
  7. Crash

    aa Crash func_nerd

    Messages:
    3,148
    Positive Ratings:
    4,746
    Would there have to be a refresh of some kind before this change would take effect? I changed it to -1 and loaded up hammer but everything was still blurry.
     
  8. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    hmm, dunno. I actually haven't tried it lately and my computer with hammer on it is out of commission for a week or two so I can't test it.
     
  9. Egan

    aa Egan

    Messages:
    1,305
    Positive Ratings:
    1,486
    I had it happen to me the other day as well, and I did the -1, reloaded hammer, was blurry, was like 'shit' and then the next time after that I loaded up hammer it was all fixed. so maybe try just reloading hammer some more. :p
     
  10. Crash

    aa Crash func_nerd

    Messages:
    3,148
    Positive Ratings:
    4,746
    So I waited a few days and a few resets, still blurry. :bored:
     
  11. luxatile

    aa luxatile deer

    Messages:
    2,289
    Positive Ratings:
    1,348
    I set mat.picmip to -1 in group 14 and it didn't work, but then I set it to -1 in like... 12, 13 and probably some others too, and it worked. Yay.
     
  12. Crash

    aa Crash func_nerd

    Messages:
    3,148
    Positive Ratings:
    4,746
    Changed 13 last night and it didn't work, but today I booted up and everything is crisp again.

    Not sure if it was the update or the change I made. Either way, it's working now!
     
  13. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    Changing groups 12 and 13 fixed this for me, whereas 13 alone didn't. Do both just in case I suppose.