Low quality textures in hammer.

Discussion in 'Mapping Questions & Discussion' started by Spacemonkeynz, Feb 22, 2008.

  1. Spacemonkeynz

    Spacemonkeynz L5: Dapper Member

    Messages:
    234
    Positive Ratings:
    52
    Ever since the SDK update for the orange box, the textures in the 3D view have been very low quality, low enough that it's impossible to figure out what certain entities are just my looking at them, and it makes aligning textures very difficult.

    I've search around and found out some other people have the problem as well. But does any one know how to fix it?
     
  2. Armadillo of Doom

    aa Armadillo of Doom Group Founder, Lover of Pie

    Messages:
    949
    Positive Ratings:
    614
    Could you post some screens? I've never heard of this before. Are there any graphic settings for Hammer? I've never had to mess with them, so I don't know. Is it possible Hammer detected low settings for your computer?
     
  3. Spacemonkeynz

    Spacemonkeynz L5: Dapper Member

    Messages:
    234
    Positive Ratings:
    52
    There are no graphics settings, which I believe is the problem, so hammer choses them for you, and there is no way to change them.

    It happen with the SDK upgrade for the orange box, before my textures were fine.

    [​IMG]
    As you can see, entity names can be quite hard to see, and some textures which have lots of detail in game just appeared as a blurred mess in hammer, making it impossible to align and rotate some texture so they look right.
     
  4. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,741
    So you are using the beta SDK? try switching back to the normal SDK
     
  5. Spacemonkeynz

    Spacemonkeynz L5: Dapper Member

    Messages:
    234
    Positive Ratings:
    52
    No, i'm using the normal SDK.

    I did try switching to the new beta SDK to see if that would fix the problem, but it's just the same, so I went back to the normal SDK.
     
  6. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    It has been like this for me and many other people as well ever since the orange box SDK... nothing can be done but getting used to it and waiting for valve :|
     
  7. Spacemonkeynz

    Spacemonkeynz L5: Dapper Member

    Messages:
    234
    Positive Ratings:
    52
    I found a fix here http://www.mail-archive.com/hlcoders@list.valvesoftware.com/msg23543.html

    dxsupport.cfg appaers to contain all graphics information for the types of graphics cards.

    There were a few (10 or so) "ConVar.mat_picmip" lines, I just replaced them all.

    Anyway, now my textures in hammer are perfect :D
     
    • Thanks Thanks x 2
    Last edited: Jul 13, 2008