Looped .wav file sounds 'glitchy'

Discussion in 'Mapping Questions & Discussion' started by Werewolf, Mar 17, 2019.

  1. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    853
    Positive Ratings:
    268
    I'm trying to work on an update to DR_Bank, and one point of feedback I had seen was about compressing my sound files. After trying to compress them I have found that Gaben's (the motivator) move sound became distorted. I heard the bug and tried to revert the change by extracting the same file from a previous version of the map, one I knew it worked on. Except its still doing it with the un-compressed sound file and I can't figure out why.

    The sound file is an uncompressed .wav file, with loop flags added in Wavosaur. When I test the map on my PC, it sounds fine. But when I test the map on my Laptop, it sounds 'glitchy'. I wish I could record what it sounds like, but I can't do that on my laptop (I tried to record a demo then play that demo back on my PC to record that, but my PC plays the sound back fine)

    This is the file's properties according to Wavosaur:
    [​IMG]

    I have tried a couple things to fix it, namely:
    • Making a soundscript for the sound so the game can call that rather than the file directly, to no effect.
      In case anyone wants to see, this is my soundscript for the file:
      Code:
      "gaben_move_loop"
      {
         "volume"     "1"
         "wave"   "custom\dr_bank\gaben_move_loop.wav"
      }
    • The sound file was being called from the func_tracktrain entity, via it's 'Move Sound' entry. I have tried using an ambient_generic and setting the sound source (where it will make the sound appear to come from) as the func_tracktrain.
    • I've tried making the ambient_generic call the soundscript and the .wav file directly.
    I think the only other thing I haven't tried is converting the sound file to a .mp3 and using a logic_timer to make the sound play every 1 second, which feels rather hacky to me.

    So, does anyone here have any ideas or suggestions as to what is wrong or how to fix it?
     
  2. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    853
    Positive Ratings:
    268
  3. ficool2

    ficool2 L5: Dapper Member

    Messages:
    237
    Positive Ratings:
    190
    Go to your TF2 root folder, search for "cache" in Windows and delete anything that appears, then see if the sound issue gets fixed
     
    • Respectfully Disagree Respectfully Disagree x 1
  4. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    853
    Positive Ratings:
    268
    I did this on my laptop and noticed when I loaded my map again it said:
    Code:
    ] map dr_bank_v10
    Saving C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\tf2_sound_misc.vpk.sound.cache
    Seemed to take longer for the map to load as well. The good news is it worked, thank you.

    Thing is, won't everyone who loads this map have to delete that sound cache file?
     
    Last edited: Mar 17, 2019
  5. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    853
    Positive Ratings:
    268
    OK, I have to remove my thanks and add a 'Respectfully Disagree' here.

    Prior to asking here, I asked the same question on the Fortress Labs Discord. The answer I got there appears to be the correct one, in that deleting my sound cache files does not fix the issue for everyone else. They would all have to do that if they had played a previous version of the map. Given how popular the map is, that is very likely.

    The correct fix is to rename the sound file so that players games are called the new compressed sounds not the old uncompressed ones.
     
    • Agree Agree x 1