Lighting weird when compiled on HDR....

Discussion in 'Mapping Questions & Discussion' started by cornontheCoD, Mar 4, 2009.

  1. cornontheCoD

    cornontheCoD L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    70
    On my map, the lighting is weird (dark) when it's compiled on HDR. But when it's compiled only on normal lighting, it is just fine. Anyone know what's causing this?

    Edit: and yes, I have HDR brightness on my sun and in my lights
     
  2. Icarus

    aa Icarus

    Messages:
    2,246
    Positive Ratings:
    1,182
    screens would be nice :)
     
  3. cornontheCoD

    cornontheCoD L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    70
  4. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    Drawing a blank on the name. There's an entity for controlling bloom and max/min hdr levels. I'll have to search for the name...
     
  5. Apom

    Apom L6: Sharp Member

    Messages:
    366
    Positive Ratings:
    62
    env_tonemap_controller (must be fired through logic_auto with SetAutoExposureMin 0.5 ~0.8, SetAutoExposureMax 1.1~1.3, SetBloomScale 0.3~0.7).
     
  6. Spike

    Spike L10: Glamorous Member

    Messages:
    716
    Positive Ratings:
    82
    well, those values above are not obligatory, just experiment with them so it fits with your map
     
  7. cornontheCoD

    cornontheCoD L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    70
    I have an env_tonemap controller. I am also trying to stress that I have compiled this map (an earlier version, b5) before on HDR, and it worked fine.