Lighting Problems and Lack of Control

Discussion in 'Mapping Questions & Discussion' started by ellacourn, Jun 12, 2014.

  1. ellacourn

    ellacourn L1: Registered

    Messages:
    16
    Positive Ratings:
    5
    So, I decided to try to build a small yet simple level ( and when I mean simple, I mean four walls with a light and one team spawn à la "Your First Map" tutorial on the Valve Developer Wiki ) via the Hammer editor located in my "I:\Program Files\Steam\SteamApps\common\Team Fortress 2\bin". I compiled the map with the settings of:

    Run BSP * Normal
    Run VIS * Normal
    Run RAD * Normal
    [X] Don't run this game after compiling
    And an Empty Additional Game Parameters

    I saved the map in my "I:\Program Files\Steam\SteamApps\common\Team Fortress 2\tf\maps" folder and compiled it. I had no compilation errors to speak of as I put it through Interlopers Compile Log Checker. So, I closed Hammer and ran the map via "map test_map" aaaaand...

    There was no lighting. Like, at all. As in, the lighting I specifically put in there that should've shown up... Didn't. And even worse, I tried to select a class and it wouldn't work. As in, I couldn't even move the scout or shoot. I don't know what's happening with the map and I'm unsure if I did something wrong or not.

    Any ideas?

    Here's the compile logs:
    http://pastebin.com/vuyxi2nr

    Here's the actual console readout:
    http://pastebin.com/AzyD2UDB

    and here's a screenshot of what actually happened:
    http://steamcommunity.com/sharedfiles/filedetails/?id=270077068

    And yes, I know there was a similar problem found here: http://forums.tf2maps.net/showthread.php?t=22592 but I know that my issue seem to happen no matter how my brushes were orientated and my spawn point wasn't badly placed.

    ( Also, sorry for the rather strange way of posting these files... I'm new to this. )
     
    Last edited: Jun 12, 2014
  2. ManBeaR

    ManBeaR L2: Junior Member

    Messages:
    78
    Positive Ratings:
    15
    You are probably spawning in the void. make sure that the spawn positions are at least 8 units from the floor.
     
    • Thanks Thanks x 1
  3. ellacourn

    ellacourn L1: Registered

    Messages:
    16
    Positive Ratings:
    5
    Hey it worked! ( Well, it glitched out and quit to desktop but it worked!)
    Thanks for the help.
     
  4. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    You probably crashed to desktop due to an bug which annoys everyone of us.
    If you load a map with the "map <mapname>" command, then you have to restart the game to use this command again or you crash :I
    You have to change the map with "changelevel <mapname>" without disconnecting to main menu, to avoid crashes.