Lighting issues

Discussion in 'Mapping Questions & Discussion' started by HMK-3, Sep 11, 2014.

  1. HMK-3

    HMK-3 L2: Junior Member

    Messages:
    56
    Positive Ratings:
    14
    Hi, i have a very odd (At least for me, im new in hammer) problem with the lighting. im making a CTF map, so i copied, pasted, and rotate the map, and the duplicated part has some black spots in the walls, i dunno if it is the visleafs have anything to do with this. :/
    Thanks for reading this grammatical hell :O

    The Original
    [​IMG]

    The Copied
    [​IMG]
     
  2. henke37

    aa henke37

    Messages:
    1,836
    Positive Ratings:
    420
    try checking with fullbright 2 to see just the lightmap.
     
    • Thanks Thanks x 1
  3. Lampenpam

    aa Lampenpam

    Messages:
    994
    Positive Ratings:
    329
    Do you have two identical brushes on the same spot?
     
    • Thanks Thanks x 1
  4. wareya

    wareya L7: Fancy Member

    Messages:
    493
    Positive Ratings:
    172
    The lighting is slightly darker overall. Did you accidentally add distance limits to the lights? Did your map leak? Did you compile with full vis and vrad?

    Do you have a 3D skybox that overlaps the new part of the level? VRAD considers gameplay area and 3d skybox to be the same geometry for accuracy reasons.
     
    • Thanks Thanks x 1
    Last edited: Sep 11, 2014
  5. henke37

    aa henke37

    Messages:
    1,836
    Positive Ratings:
    420
    I think this might be a genuine compiler bug. Luckily, just moving the map dodges it.
     
    • Thanks Thanks x 1
  6. HMK-3

    HMK-3 L2: Junior Member

    Messages:
    56
    Positive Ratings:
    14
    Its has been compiled in fast/full, i have no 3D Skybox, i dont messed up the lights, and i dont hace 2 brushes.

    i will try to move it, i just moved a ligth and got fixed XD