Light Issue

Discussion in 'Mapping Questions & Discussion' started by Kelee, Apr 10, 2012.

  1. Kelee

    Kelee L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    Hey everyone, finally starting my map again and I came across a really weird issue. The shadows on my particular piece (and others but not as much) looks awful.

    My question(s):
    1) Can I remove all shadows from a map?
    2) Can I remove certain items from having shadows?
    3) Do sky boxes effect this?

    [​IMG]
    As you can see it looks awful with said shadows and on the right side it doesn't even have one (For some reason).
     
  2. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,113
    Positive Ratings:
    6,084
    1) apart from full bright mode, no.
    2) Yes. Open the prop and change disable shadows to on.
    3) no more than other lights
     
  3. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,113
    Positive Ratings:
    6,084
    1) apart from full bright mode, no.
    2) Yes. Open the prop and change disable shadows to on.
    3) no more than other lights
     
  4. Kelee

    Kelee L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    Thank you for the quick response, sadly I do not know what you mean. The only prop I am using (for light) is light_environment. I do not see the "disable shadows" and the other objects are materials not props. I will however use that in the future (when I start adding props).


    Thank you.
     
  5. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    393
    Then it's likely those shadows are being cast by brushes, which you cannot directly do anything about.

    You could turn them into func_brush entities and disable shadows that way. Select the brushes making offending shadows and hit ctrl+t. In the window that pops up, type func_brush in the text box and hit apply. Then in the values that appear, disable shadows.

    This does mean the brush will no longer be considered map geometry, which means it can't seal the map, and won't block vis. Which is probably fine for what you're doing here but keep it in mind.


    Another option may be to mess with the lightmap scale on the surfaces receiving shadows you do not want to see. Select the face that you do not want to receive shadows with the texture select tool, and change the lightmap setting to 64 or 128.

    This doesn't technically eliminate the shading, but it makes it so diffuse you won't be able to see it.
     
    • Thanks Thanks x 1
  6. Kelee

    Kelee L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    I tried the func_brush, seems to work fine but I noticed sticky bombs roll off instead of sticking, not a huge deal.

    I will try the lightmap scaling on other objects when the need arises.


    One last question as mentioned above you can use fullbright, when I think of fullbright I think of a way to exposed area that makes your eyes hurt. I'd assume this is the same way in-game? If it is, is it possible to dull the fullbright and make less bright?
     
    Last edited: Apr 10, 2012
  7. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    393
    No, fullbright is all or nothing.

    You should never release a map with fullbright because everything will look terrible, and people will laugh at you for making a newbie mapper mistake.

    It technically only exists to be used for map development, so you can see the map before lighting has been developed.
     
    • Thanks Thanks x 1
  8. Kelee

    Kelee L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    Figured as much, thank you for your help. T'is seems to work good enough, don't think anyone will notice otherwise.
     
  9. Kelee

    Kelee L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    Another question, didn't want to make a new thread so I shall post here!

    Glass issue, in hammer it looks awesome, in-game it is glitched and poopy looking.

    Images:

    In hammer:

    [​IMG]

    In-game:

    [​IMG]

    Why is this? And how in the heck can I fix it?
     
  10. Bereth

    Bereth L3: Member

    Messages:
    127
    Positive Ratings:
    78
  11. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,632
    Positive Ratings:
    1,723
    you need cubemaps to fix this. with cubemaps you'll get a reflection instead of those pink shapes
     
  12. Kelee

    Kelee L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    Oh, I know that, I was talking about the pillars and how you can't see the 3D aspect of them through the glass in-game. I have tried no-draw to no avail.
     
  13. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    393
    Either make the pillars func_detail, or slightly thicker than the glass.

    Map compilation deletes faces that it considers "non visible", and it doesn't take into account texture transparency when doing it.

    nodraw is definitely not what you want, anything with that texture will not be visible in game at all.