Leak - Problems

Discussion in 'Mapping Questions & Discussion' started by Simulacron, Mar 4, 2016.

  1. Simulacron

    Simulacron L6: Sharp Member

    Messages:
    299
    Positive Ratings:
    151
    I have a really weird Problem. When I compiling my map the compile log says I have a leak in my map. I already checked this on interloper.net, and it finds following Problems:
    findportalside: couldn't find a good match for which brush to assign to a portal near (3072.0 2560.0 -96.0)
    Description:
    This error is usually followed by something like this:

    Leaf 0 contents:(may vary)
    Leaf 1 contents: CONTENTS_SOLID (may vary, e.g. CONTENTS_WATER)
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID (ditto)
    This means that none of the brushes in leaf 0 or 1 that touches the portal
    has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents
    CONTENTS_SOLID
    Candidate brush IDs: [none or more brushnumbers]
    Usually, this error is caused by a leak, so fix it if it is.
    If it isn't, there is a (group of) brush(es) that is/are giving vbsp.exe a hard time to figure out your level.
    Apparently it cannot determine the boundaries of a certain portal. Maybe there is a large brush covering the area, maybe the area is just to complicated for poor vbsp to figure out.

    I don't know the details but usually turning entities to world brushes or vice-versa helps to fight the problem. Hell, just cutting a brush in two once helped me fight this problem.

    Solution:
    Find the given coordinates (or if a brush number is given search for the brush number) and see what you can do to to simplify the area (like turning brushes to func_detail). You should also check to see if the brushes are overlapping at any point.

    entity trigger_multiple (704.00 3248.00 48.00) leaked!
    Description:
    You have a leak. A leak is a hole in your map that exposes any entity in your map to the void (the black space outside your map).

    Solution:
    Fix the leak.

    **** leaked ****
    Description:
    You have a leak. A leak is a hole in your map that exposes any entity in your map to the void (the black space outside your map).

    Solution:
    Fix the leak.

    When I go to the coordinates from Problem1 there is nothing, just the void.
    When I go to the leaked trigger multiple there is also nothing, as you can see in this picture:
    [​IMG]
    How can I solve this problem?
     
  2. JMaxchill

    JMaxchill L5: Dapper Member

    Messages:
    220
    Positive Ratings:
    64
    That red line in your screenshots goes from the entity, through the leak, into the void. Follow it back and you should find your problem
     
  3. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,003
    Positive Ratings:
    1,155
    The trigger_multiple's origin is probably outside the map. Assuming that's the cause, if you toggle helpers on :helpers: and select your entire map, a small red circle will appear there in the 2D views. Either drag it back inside the map, or select the trigger brush and click Tools > Center Origins. The first error normally appears alongside leaks so you should be good to go once you fix your origins.
     
    • Thanks Thanks x 1
    • Like Like x 1
  4. Simulacron

    Simulacron L6: Sharp Member

    Messages:
    299
    Positive Ratings:
    151
    Thank you really much, that was the problem