Just started building, i have a few questions

Discussion in 'Mapping Questions & Discussion' started by RoosterMisfit, Sep 28, 2016.

  1. RoosterMisfit

    RoosterMisfit L1: Registered

    Messages:
    20
    Positive Ratings:
    1
    Hey! just started building a map a couple of days ago and i have ran in to a few snags.

    I have been watching tutorials on youtube to learn but from what i have seen the problems i have arent listed. I use Hammer

    so here they are

    when i test run the map, the props dont show up in the map.

    when editing my props show up as blocks unless i get close. - http://imgur.com/uZWCUsr

    hitting run used to work fine but now it has nothing in the compile run commands and i dont know how to run it otherwise - http://imgur.com/a/pvRTy
     
  2. Moonrat

    aa Moonrat The end of an era

    Messages:
    897
    Positive Ratings:
    530
    I can't diagnose the first problem, but if I had to guess, you might be using the wrong class of prop. Make sure anything that doesn't have IO or Physics attached to it is a prop_static

    As for the second thing. Just go to Hammer's options window. You should find a slider in the 3D View options that lets you choose how far you have to go before props unrender.

    As for the final problem, just switch it to a normal compile, rather than using expert.
     
  3. RoosterMisfit

    RoosterMisfit L1: Registered

    Messages:
    20
    Positive Ratings:
    1
    i dont know what IO is but it is a static prop directly copied from the prop library. tried copying over the australium rocket and its in my editor but when i run it, its not there

    other 2 problems fixed, thanks
     
  4. RoosterMisfit

    RoosterMisfit L1: Registered

    Messages:
    20
    Positive Ratings:
    1
  5. sooshey

    aa sooshey :3c

    Messages:
    522
    Positive Ratings:
    418
    The rocket is supposed to be a prop_dynamic because it's meant to move
     
  6. RoosterMisfit

    RoosterMisfit L1: Registered

    Messages:
    20
    Positive Ratings:
    1
    i dont want them to move, i want them to sit still like they are in storage
     
  7. sooshey

    aa sooshey :3c

    Messages:
    522
    Positive Ratings:
    418
    Doesn't matter, set them to prop_dynamic anyway. They won't move as long as you don't tell them to with inputs. If you need the rocket to be solid, use the one without a cap (rocket_base_doomsday.mdl) and put the cap model on top yourself.
     
  8. RoosterMisfit

    RoosterMisfit L1: Registered

    Messages:
    20
    Positive Ratings:
    1
    ah ok, i see, it works now. is there no way to make the rocket with the top solid?
     
  9. sooshey

    aa sooshey :3c

    Messages:
    522
    Positive Ratings:
    418
    You can either set the collisions to "use bounding box" (which will make it solid in the shape of the yellow box that appears around it when selected), or you can try to match the shape using blockbullets brushes. But I think it would be easier to use the cap-less rocket and put the cap model on top. It's on the ground next to it in the prop library.
     
  10. RoosterMisfit

    RoosterMisfit L1: Registered

    Messages:
    20
    Positive Ratings:
    1
    with the capless one i noticed the thrusters at the bottom dont show up. they show in the editor but not the the test run. is that common or did i do something wrong?