Model Jigglebones?

Discussion in 'Request Area' started by SiniStarR, May 28, 2010.

  1. SiniStarR

    SiniStarR L8: Fancy Shmancy Member

    Messages:
    585
    Positive Ratings:
    116
    To you modeler out there, help me out! I've been trying to crack the mysteries of the Jigglebone in 3ds max. There is this tutorial on youtube:
    http://www.youtube.com/watch?v=tmfK-xlNn88

    The tutorial goes through the process of making the scout's bat jiggle. I did nearly everything identically, except I used a cylinder, used just the null textures and used 3ds max 2011 yet I was still not successful. In my Compiler it say it compiles just fine but when you go open it, the model viewer, it tells me that it is unable to open it.

    I went and checked my files and the model is 1-2kb. I've had this issue before but with other models, but this is a first with jigglebones. I checked the compile log and it states this:
    Marking bone jiggle1 as a jiggle bone
    Marking bone jiggle2 as a jiggle bone
    Marking bone jiggle3 as a jiggle bone
    Marking bone jiggle4 as a jiggle bone
    jigglebone "jiggle1" unused
    jigglebone "jiggle2" unused
    jigglebone "jiggle3" unused
    jigglebone "jiggle4" unused

    This did not come up in the youtube tutorial, and google has failed me, I can't find any explanation on this specific problem.
    Any ideas and suggestions would be most appreciated thanks!
     
  2. Mick-a-nator

    aa Mick-a-nator

    Messages:
    640
    Positive Ratings:
    314
    have you made sure that the bones are linked to vertices? either with envelopes or with vertex paint.

    sorry if that's a stupid question, I don't know your modelling ability.
     
    • Thanks Thanks x 1
  3. SiniStarR

    SiniStarR L8: Fancy Shmancy Member

    Messages:
    585
    Positive Ratings:
    116
    Much to my embarrassment, I solved it. This time starting over but with the Scout's decompiled Bat. It worked just fine. Weird how a cylinder would refuse to work. To make sure it wasn't all geometry I tried the same procedure but with a plane. That worked! I suppose Jigglebones do not like 3ds max cylinders. Thanks for your times everyone >_<