Issues with inserting custom particles into a map.

Discussion in 'Mapping Questions & Discussion' started by Pikmin 23, Oct 8, 2009.

  1. Pikmin 23

    Pikmin 23 L1: Registered

    Messages:
    40
    Positive Ratings:
    0
    I'm having some issues with a custom particle that a friend made for me. The particle works when I test my map, without having pakratted anything in, but when I insert the particle using pakrat it no longer works. I'm adding both the particle_manifest.txt (From my maps folder) and the particle file itself, yet it still doesn't work.

    So, anyone know how I'd be able to get this working?
     
  2. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,465
    You have to rename your manifest to yourmapname_particles.txt and pakrat it in the maps folder.
     
  3. Pikmin 23

    Pikmin 23 L1: Registered

    Messages:
    40
    Positive Ratings:
    0
    I just tried that, and it still doesn't seem to work.
     
  4. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,465
    You have your manifest in the maps folder and your particles in the particle folder, correct?
     
  5. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Try using bspzip. I had a similar problem with pakrat, and I suspect there was some sort of file corruption or bad pathing going on.

    Which is why I'm working on a replacement :p
     
  6. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,465
    Oh, and FYI you have to manually type the folder name out when you pakrat the content otherwise it ends up going in the root of the BSP.
     
  7. Pikmin 23

    Pikmin 23 L1: Registered

    Messages:
    40
    Positive Ratings:
    0
    I have them added as:

    2012_core.pcf | particles/
    pl_2012_a10_particles.txt | maps/

    I'm pretty sure it's just something I'm doing wrong.
     
  8. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,465
    No need for the slashes. ;)
     
    • Thanks Thanks x 1
  9. Pikmin 23

    Pikmin 23 L1: Registered

    Messages:
    40
    Positive Ratings:
    0
    It's still not working. After my friend activated the particles via ent_fire:

    Attempting to create unknown particle system 'nucleus_finale'
    KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file maps/pl_2012_a10_particles.txt
    xtpl_2012_a10_particles,
    Unable to read particle definition particles/2012_core.pcf! UtlBuffer is the wrong type!

    So I honestly don't know what's going on. Anyone know what this means, apart from the particle not working? Could someone give me a step-by-step tutorial to make sure I haven't messed anything up?
     
  10. The Political Gamer

    aa The Political Gamer

    Messages:
    4,468
    Positive Ratings:
    1,682
    [ame="http://forums.tf2maps.net/showthread.php?t=8107"][Particles] Weather Effects with Collisions! - TF2Maps.net[/ame]
     
    • Thanks Thanks x 1
  11. Pikmin 23

    Pikmin 23 L1: Registered

    Messages:
    40
    Positive Ratings:
    0
  12. Pilk

    Pilk L2: Junior Member

    Messages:
    66
    Positive Ratings:
    4
    :D, etc.