Issue with Respawn Room Visualiser

Discussion in 'Mapping Questions & Discussion' started by MegapiemanPHD, Jun 11, 2018.

  1. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    972
    Positive Ratings:
    485
    I've been having this odd issue with respawnroomvisualiser entities

    20180611185704_1.jpg

    I have 4 spawn exits on the map and no matter what I do one of them has this problem. If I fix one, it happens on another and just moves around and around without going away. Anyone got any ideas?
     
  2. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    757
    Positive Ratings:
    516
    I have this problem too sometimes, never figured out how to fix it. My guess is it's just a bug with the entity and z-sorting.
     
  3. ics

    aa ics http://ics-base.net

    Messages:
    694
    Positive Ratings:
    421
    Do a full compile, build cubemaps and see if it works ok. I've had this issue too.
     
  4. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    972
    Positive Ratings:
    485
    Still the same issue. I've been told it's a Source engine problem and there's nothing that can really be done about it :/
     
  5. ics

    aa ics http://ics-base.net

    Messages:
    694
    Positive Ratings:
    421
    You can also recreate the whole brush. Delete and do it again. I've had similar issue on 2 of my maps. The other was fixed by full compile, and the other was fixed by recreating the brush.
     
  6. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    972
    Positive Ratings:
    485
    I've recreated the brushes multiple times to no avail.
     
  7. AlexCookie

    aa AlexCookie Suspect of eating cookies alive

    Messages:
    268
    Positive Ratings:
    526
    Try moving visualiser's origin forward a bit so it's in front of the door.
    upload_2018-6-12_21-25-56.png upload_2018-6-12_21-25-24.png
     
  8. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    972
    Positive Ratings:
    485
    That's a good idea but the visualizer doesn't have a white circle. That or I'm missing something.
     
  9. AlexCookie

    aa AlexCookie Suspect of eating cookies alive

    Messages:
    268
    Positive Ratings:
    526
    That's because you don't have helpers :helpers: enabled
     
  10. Umaroth-24

    Umaroth-24 L2: Junior Member

    Messages:
    63
    Positive Ratings:
    33
    Maybe another solution is to copy paste another visualizer at the same spot, which works for me
     
  11. [Rx.] Christian Troy

    [Rx.] Christian Troy L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    50
    I had this issue a few times. For me the solution was to back it up and or shorten the brush to be one or two units away from the door prop. I had them even with the backs of the doors.
     
  12. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    972
    Positive Ratings:
    485
    I do have it enabled

    I've tried that a few times already to no avail.

    I'll give that a shot.
     
  13. ϺΞΤЯΘΉλϺ

    ϺΞΤЯΘΉλϺ L3: Member

    Messages:
    102
    Positive Ratings:
    54
    tbh, I've seen that on many valve maps(Such as Hydro & 2fort, for example). Could be just a source engine thing but I mean, shouldn't be a big problem if the opposite team knows it is enemy spawn.
     
  14. AlexCookie

    aa AlexCookie Suspect of eating cookies alive

    Messages:
    268
    Positive Ratings:
    526
    Make sure you have "Groups" or "Objects" selected not "Solids"
     
    • Agree Agree x 1
  15. MegapiemanPHD

    aa MegapiemanPHD Doctorate in Deliciousness

    Messages:
    972
    Positive Ratings:
    485
    Still not there.