Issue with func_respawnroom no_entry texture showing up

Discussion in 'Mapping Questions & Discussion' started by Polar-Star, Jun 6, 2017.

  1. Polar-Star

    Polar-Star L1: Registered

    Messages:
    18
    Positive Ratings:
    0
    Whenever I get close to the door I'm making, the No Draw material doesn't display infront of my door and it displays incorrectly and I have no idea how to fix it. If anyone could tell me how to fix it I'd be really helpful. I've just started map making yesterday so I don't know a lot about it.
     

    Attached Files:

  2. Diva Dan

    aa Diva Dan hello!

    Messages:
    831
    Positive Ratings:
    1,369
    Is the brush with the no entry texture the same size as the doorway? Can we see a screenshot comparing the size of the respawn room visualizer compared to the size of the door?
     
  3. Polar-Star

    Polar-Star L1: Registered

    Messages:
    18
    Positive Ratings:
    0
    No, but at one point I did have it the same size, the same problem happened[​IMG] [​IMG]
     
  4. seta_samuli

    seta_samuli L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Have you tried camera -> 3d textured
    instead of textured shaded polygons?
     
  5. Polar-Star

    Polar-Star L1: Registered

    Messages:
    18
    Positive Ratings:
    0
    I use 3D Textured, plus it's a problem in game not in Hammer
     
  6. Another Bad Pun

    Server Staff Another Bad Pun learning to fly

    Messages:
    578
    Positive Ratings:
    1,177
    Which no entry texture are you using?
     
  7. Polar-Star

    Polar-Star L1: Registered

    Messages:
    18
    Positive Ratings:
    0
    Regular "no_entry"
     
  8. MOCOLONI

    MOCOLONI L5: Dapper Member

    Messages:
    243
    Positive Ratings:
    60
    First of all, the screenshot you're showing in-game is the RED spawn, while the one taken from Hammer is the BLU spawn's one. Second, nobody listened to me when I reported the entity's visual glitch so it hasn't been said in your post earlier: this is a bug from Valve's side and not yours. The game is so broken to a point where they break the most unrelated things, some of them being the info_observer_point entity (official Casual/Competitive servers) and the func_respawnroomvisualizer (any server). Apparently, the overlay is only seen over static brushes and props. However, if you reload the map or load it after another one, the overlay will be showing up properly on all surfaces.
     
    Last edited: Jun 7, 2017
  9. Polar-Star

    Polar-Star L1: Registered

    Messages:
    18
    Positive Ratings:
    0
    The reason for the different sides are because at the time, the RED side was having issues and the BLU side worked. When he asked for more pictures, I had tried to fix the door and change things and at the time the RED side worked, and the BLU side broke, so I figured I should send a picture of the one that was breaking. But thank you for explaining the bug :^)
     
  10. AlexCookie

    aa AlexCookie Suspect of eating cookies alive

    Messages:
    250
    Positive Ratings:
    505
    Try moving func_respawnroomvisualizer's origin so it is in front of the door, that worked for me.
     
  11. Polar-Star

    Polar-Star L1: Registered

    Messages:
    18
    Positive Ratings:
    0
    It was in the first picture
     
  12. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    No it isn't as we can see from your hammer screnshot. He is talking about the entity's "origin", which is the blue point floating in its center in the 3D view when it is selected. You can move this point in the 2D viewpoints.