Is It Just Me? Hammer Crashing While Clicking Flags

Discussion in 'Mapping Questions & Discussion' started by Beetle, Oct 27, 2013.

  1. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    This is very much the cause - Clicking the Flags tab causes my Hammer Editor to crash more times than not. I've tried your everyday solutions - defragging, verifying, fresh install. So I ask this: If there was some sort of Hammer crash log, where is it? and also, if anyone has fixed it, how!? It drives me insane. I can almost count on it to crash when clicking the Flags tab of an entity.
     
  2. Bombcartography

    Bombcartography L1: Registered

    Messages:
    25
    Positive Ratings:
    7
    I was having problems where if I tried to open the input/output tabs of an entity, it would lock up which sounds similar to your problem. Does it happen even if you've just started Hammer?

    I've noticed in the past six months or so that the longer I keep it open, the more memory it consumes and the more unstable it becomes. If I open and close other vmfs, they don't leave the memory, and it becomes unstable more quickly. Hammer sometimes was consuming 2.5 GB of RAM. Perhaps it's always been like this, but I don't remember it being so.

    So now I keep task manager open and if hammer hits 1GB, I save and restart. And if I open another vmf, I go ahead and restart.
     
  3. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    There's no way I have found to completely avoid it, and yes, it does crash after just opening hammer. It crashes on small maps, old maps, new maps, and large maps. It's just inconsistent.

    For me, it hasn't always been like this, but it has been like this for a while now.
     
  4. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    I haven't been mapping in ages, but in the past this was an occasional problem for me. I never found a fix but it didn't happen often enough that I really looked into it. (and my subconscious ctrl+s twitch meant I rarely lost anything)
     
  5. s0da72

    s0da72 L2: Junior Member

    Messages:
    74
    Positive Ratings:
    17
    I've noticed that hammer is crashing when I try to load in one of my maps. This started to happen after the Halloween update. I can load in some maps without issue but not all.

    Anybody else seeing this issue?
     
    • Thanks Thanks x 1
  6. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    just tested. seems fine to me.
     
  7. Bloodroke

    Bloodroke L1: Registered

    Messages:
    29
    Positive Ratings:
    8
    I too have just noticed this. It seems that after Valve's massive screw-up update in which they've managed to break everything possible, certain entities when either placed while editing or loaded up into a map during the loading process cause Hammer to crash.

    This worries me; I don't want my maps to be corrupted or something. I certainly hope Valve fixes their massive goof.
     
    • Thanks Thanks x 1
  8. Crash

    aa Crash func_nerd

    Messages:
    3,130
    Positive Ratings:
    4,710
    I'm getting this also, can't load any of my maps. Crashes at about 33% load.
     
    • Thanks Thanks x 1
  9. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    After a couple tests, it appears to be some issue with my FGD. I'll be looking into it right now. In the mean time if you have need to map tonight you can go to Tools>Options>GameConfigurations and remove tf-abs.fgd from the list and add tf.fgd back in.

    edit: sorry, to be clear. I am talking about the crash-upon-load as of the halloween update. Not the flags tab crash.
     
    • Thanks Thanks x 3
    Last edited: Oct 29, 2013
  10. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    well I have a simple map with your basic entities that doesn't crash hammer, so it's gotta be something a little bit less common.
     
  11. s0da72

    s0da72 L2: Junior Member

    Messages:
    74
    Positive Ratings:
    17
    That fixed my issue
     
  12. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    doop derp. Pack/FGD updated to resolve that issue and integrate a few new features.
     
    • Thanks Thanks x 2
  13. Penguin

    aa Penguin Clinically Diagnosed with Small Mapper's Syndrome

    Messages:
    1,992
    Positive Ratings:
    1,233
    Hammer has been crashing hard from doing just about anything for me.
     
  14. Bombcartography

    Bombcartography L1: Registered

    Messages:
    25
    Positive Ratings:
    7
    Steam Updated this afternoon and uninstalled SDK. Things look different. I haven't installed SDK in over a year or so. I'm assuming I should install Source SDK Base 2013 MP. But I'm not sure if this is all new and will affect how your pack installs.
     
    Last edited: Oct 31, 2013
  15. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    o_O I have no idea... all my SDK stuff is still here. But in your case, the "SDK Base" stuff has to do with running mods, not making stuff.
     
  16. Bombcartography

    Bombcartography L1: Registered

    Messages:
    25
    Positive Ratings:
    7
    I see what I did now. SDK is in my favorites at the top of the tools now. I moved it at some point and forgot. Apparently the update broke IcyEyes' friendly launcher. It can't find SDK. So when I looked to where SDK usually was to attempt to launch from there, I couldn't find it either. So I thought it had been removed.

    Edit:

    TF2 updated this morning and now the friendly launcher is working again.
     
    Last edited: Oct 31, 2013