Indoor Lighting Too Dim

Discussion in 'Mapping Questions & Discussion' started by MagnusMastah, Nov 17, 2008.

  1. MagnusMastah

    MagnusMastah L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    Hey guys, I have four indoor light_spots in a spawn room, but even at 500 brightness, they're WAYYY too dim. I have two screenshots, one of my settings of the lights in Hammer, and the other of their in-game brightness. Sorry, I'm brand new to mapping. :)

    [​IMG][​IMG]

    [​IMG][​IMG]

    The odd thing is, the light_environment that I have outside works perfectly; the way it should. Thanks for any help in advance.
     
    Last edited: Nov 17, 2008
  2. TheDarkerSideofYourShadow

    TheDarkerSideofYourShadow L10: Glamorous Member

    Messages:
    792
    Positive Ratings:
    144
    Up your brightness (try 1000+)
    Change the distances of the 50% falloff and 0% fall off. If you have helpers on in hammer (its one of the buttons more towards the right of the top tool bar) when you select a light you'll see 2 yellow circles that you can expand outwards to increase how far the light goes. The important part is that the 0% must be a greater number than the 50%.
     
    • Thanks Thanks x 1
  3. MagnusMastah

    MagnusMastah L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    My brightness is 1500, my 50% falloff is at 200 and my 0% falloff is at 400. Am I doing that right? Because I can't see any noticeable difference. :/

    EDIT: Hmm, I guess I'll probably just use regular light entities at a lower brightness, since it seems to do what I want just fine. I was just trying it with light_spots because that's what Half-Life_Maniac's Beginner's Guide to The Spawn Room was saying. Thanks for the help, though. Or is there a benefit to using light_spots that I'm not aware of?

    [​IMG][​IMG]
     
    Last edited: Nov 17, 2008
  4. TheDarkerSideofYourShadow

    TheDarkerSideofYourShadow L10: Glamorous Member

    Messages:
    792
    Positive Ratings:
    144
    They look better, and you can do a lot with them.

    Things I should have mentioned last time:
    Change the inner and outer angles. Make them something like 60 and 75, and see if thats good enough for you.
     
  5. MagnusMastah

    MagnusMastah L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    Alright, that's much better! The only problem is, now, is that the ceiling is pitch black; it doesn't look quite right.

    [​IMG]
     
  6. TheDarkerSideofYourShadow

    TheDarkerSideofYourShadow L10: Glamorous Member

    Messages:
    792
    Positive Ratings:
    144
    I would try cranking up the outer angle more, above 90, that would, in theory, project it upwards as well. Try various values. You might also want to lower your brightness a bit, now that you've got it to work its more a matter of fine tuning everything.
     
  7. bob+M|M+

    bob+M|M+ L6: Sharp Member

    Messages:
    348
    Positive Ratings:
    185
    The real problem here is that you have a leak. The light isn't reflecting against the walls like it should, and hence the stark contrast in lighting.

    Go to Map -> Load Pointfile, follow the red line and patch up your leak.
     
  8. Nineaxis

    aa Nineaxis Quack Doctor

    Messages:
    1,767
    Positive Ratings:
    1,404
    Or check if you have a light_environment to provide ambient light, which is more likely the problem than needing to mess with all the complex lighting parameters.
     
  9. drp

    aa drp

    Messages:
    2,251
    Positive Ratings:
    2,551
    every time i had this problem, i always found it to be a leak in my map. i would double check this asap.
     
  10. Captain Planet

    Captain Planet L2: Junior Member

    Messages:
    63
    Positive Ratings:
    5
    Wow, this lights look very l4d'y
     
  11. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,467
    Try these settings.

    Brightness: 255 255 255 1000
    Inner Angle: 50
    Outer Angle: 50

    Remember that light_spots need higher brightness values then your usual light and for TF2 it's best to use pale yellows and oranges for a nice warm atmosphere.
     
  12. Altaco

    Altaco L7: Fancy Member

    Messages:
    485
    Positive Ratings:
    121
    Also, make sure they're not inside a prop's collision model, that can cause some odd lighting problems. Press the "CM" button on the top toolbar to see collision models.
     
  13. Dox

    Dox L8: Fancy Shmancy Member

    Messages:
    588
    Positive Ratings:
    62
    Protip for L4D mappers: remove one outer wall you don't need!