I need tomake a waterfall

Discussion in 'Mapping Questions & Discussion' started by Kill_the_Bug, Oct 11, 2008.

  1. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,494
    Positive Ratings:
    321
    How do I do it?

    I've tried the the options here, I don't want to use that otehr dude's texture soku's or whatever his name is - says he'll sue the hell out of anyone if they make money off the map - I'm trying to do it with standard valve stuff- any ideas?

    Nothing seems to be working for me :(
     
  2. TheDarkerSideofYourShadow

    TheDarkerSideofYourShadow L10: Glamorous Member

    Messages:
    792
    Positive Ratings:
    144
    • Thanks Thanks x 1
  3. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,494
    Positive Ratings:
    321
    yea - that's what I tried :-( it not working 4 me
    in the readme file it says put the files into water folder - I made one and it didn't work for me am I doing something wrong?
     
  4. TheDarkerSideofYourShadow

    TheDarkerSideofYourShadow L10: Glamorous Member

    Messages:
    792
    Positive Ratings:
    144
    Have you closed hammer since you added it to materials/water? You shouldn't have to do anything more than the readme said.
     
    • Thanks Thanks x 1
  5. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,494
    Positive Ratings:
    321
    oh ok - I'll try that - duh - i should smack myslef sometimes - lol

    say if it works in my map - do those files need to be included for upload to a sever to run the map?
     
  6. Nineaxis

    aa Nineaxis Quack Doctor

    Messages:
    1,767
    Positive Ratings:
    1,408
    Use Pakrat to pack custom content into your map so servers don't have to upload it.
     
    • Thanks Thanks x 1
  7. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,494
    Positive Ratings:
    321
    ok still not working

    I'm trying to understand what he's saying

    1. out both files here: \team fortress 2\tf\materials\water\

    I didn't have the water folder in the materials folder - so I made it and then put the 2 files is there - correct?

    2. The files are diffferent :

    Water_Hydro_Falls
    Water_Hydro_Falls_dx80

    Do I a] have a choice over which texture to use - i.e. can use either one, or b] I have to use both tectures at the same time?

    If b] what sides to I put whicj texture one?

    3] Getting confised by this: nodraw on all sides except the water faces

    When I tried doing it on the one face - like traditional water - I see the blue box, but if I go around to the other side I see nothing - should I put the texture on all sides except the top and bottom?

    4] Do I need to configure hammer in anyway? Currently it's on standard orange box settings.


    Notes:

    Am now starting to see some texture movement - I have a blue box face with a line on it going across horizontal but that's all I see - do I need cubemaps?
     
  8. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,536
    *ninja entry* I guess I'm needed here after all! :p

    Yes, you will need cubemaps for it to work properly. I'd suggest building those first before trying anything else.

    The one without the dx80 on it is the full texture and is the one that should be used. (dx80 is for DirectX version 8 fallback).

    edit: I'm forgetting stuff about my own material! Been too long... About nodraw, what I said is exactly what I meant, only the "front" face should have the water texture on it. I think this will be more obvious and understandable once you build cubemaps and have it working.
     
    • Thanks Thanks x 1
    Last edited: Oct 12, 2008
  9. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,494
    Positive Ratings:
    321
    ok cool - but I'm a totoal noob with them - never used them before - how do I use?
     
  10. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    145
    start the map.
    open the console and type in mat_specular 0
    type in buildcubemaps
    disconnect from the game
    type in mat_specular 1
    open any other map
    disconnect
    open your map and try again :)

    EDIT: also, make sure you have at least 1 env_cubemap entity in your map, and probably one close to the waterfall.
     
    • Thanks Thanks x 1
  11. [INC] Zodiac

    [INC] Zodiac L1: Registered

    Messages:
    20
    Positive Ratings:
    0
    I always stay away from adding water to my maps. I'm not ready to handle at the moment, hopefully when I study game design more next year. I would be able to make maps like Valve in minutes with friends of course.
     
  12. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,494
    Positive Ratings:
    321
    OK, I tried doing everything mentioned above - should I make a test map and post it for you somewhere?
     
  13. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,494
    Positive Ratings:
    321
    :cursing::cursing::cursing:

    Ok this @*^@#*&^#*&!@^#* isn't working for me!

    Here's my step by step to see if I'm doing something wrong:

    1. Hammer is off.
    2. I download the zip file
    3. I put the two files in the zip into my materials folder - however, my materials folder does not have a water folder so I make it ant put the two files in there.
    4. I open Hammer
    5. I make a rectangle - with nodraw on all sides
    6. I select verticle face - put on the water_hydro_falls on it
    7. I make the cube func_illusionary
    8. I compile
    9. I run map
    10. I get a dark surface that isn't moving

    I do see this error message in console:

    Team Fortress
    Map: pl_test
    Players: 1 / 16
    Build: 3575
    Server Number: 20

    VAC secure mode disabled.
    No pure server whitelist. sv_pure = 0
    Kill_the_Bug connected
    Redownloading all lightmaps
    ShaderAPIDX8::CreateD3DTexture: Invalid color format!

    *** Tried to load a non-VTF file as a VTF file!
    Error reading texture header "materials/maps/pl_test/cubemapdefault.vtf"

    What am I doing wrong?

    edit:

    Ok dark, hope you don't mind - just trying to learn - decompiled you map - can't seem to figure out thw difference between mine and yours - yours is working :) - however, I tried the map in game - very nicely done btw - and I'm at the waterfall area - I see the same plain texture moving but no water - is it my graphics card maybe?
     
    Last edited: Oct 15, 2008
  14. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,536
    You're missing the cubemap step, for one. Place an env_cubemap a small distance (16-32) away from the water surface, then when ingame do buildcubemaps in the console, then reload the map. If it still doesn't work... we can look into if it's your video hardware.
     
    • Thanks Thanks x 1
  15. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,494
    Positive Ratings:
    321
    yep got cubemap there forgot to mention it :-(

    I brought in his waterfall into my test map - I can see a texture moving but not water - mine just sits there

    thanks for the help - it's all I need to finish my map :)
     
    Last edited: Oct 16, 2008