I got a strange bug

Discussion in 'Mapping Questions & Discussion' started by Qbus, Nov 2, 2017.

  1. Qbus

    Qbus L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    every time when I compile, I get this stupid error
    [​IMG]
    https://pastebin.com/Mt2BQwX3 <-- compile log.

    can somebody help me beacose my backup is from 10h ago (I was 10h busy creating my map...)
     
  2. ϺΞΤЯΘΉλϺ

    ϺΞΤЯΘΉλϺ L3: Member

    Messages:
    102
    Positive Ratings:
    54
    well I'm no expert but I guess its something to do with your brush that's func try going to it by searching it with the number and make sure it isn't anything it cant be ( I belive but not 100% sure)
     
  3. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,387
    Positive Ratings:
    4,220
    I've gotten that error a couple times. Deleting and remaking the entity in question usually sorts it out.
     
  4. Qbus

    Qbus L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    How can I find that entity? my map is huge.
     
    Last edited: Nov 4, 2017
  5. ϺΞΤЯΘΉλϺ

    ϺΞΤЯΘΉλϺ L3: Member

    Messages:
    102
    Positive Ratings:
    54
    I don't rember where esactly but there's a brush entity search where you put the code in it takes you to the brush, search in the tabs to see if there's a brush entity thing
     
  6. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,868
    Positive Ratings:
    4,896
    If you're spawning models somehow, like gibs from a func_breakable, you need to put them somewhere in your map as a prop_dynamic so the game loads them when the map loads. You can just hide them somewhere.
     
    • Agree Agree x 1
  7. Dr. Orange

    Dr. Orange L6: Sharp Member

    Messages:
    368
    Positive Ratings:
    278
    It does say that the model that isn't precached is called *1000, which means it's a brush model. Just try to delete or hide one func_breakable at a time until you find the one that is causing you problems.
     
  8. Qbus

    Qbus L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    nice got +200 func_breakables
    coz it's a jb map...
    but thank you all for trying to help me.
    will try this later
     
  9. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,621
    Positive Ratings:
    1,709
    quicky tip: use "Start Disabled" on the prop_dyn, then it can be placed anywhere and doesn't matter
     
    • Thanks Thanks x 2
  10. Qbus

    Qbus L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    the problem is that I didn't place any prop in a while. Like not for a month. beacose it's a minecraft map.
    but i'm still searching for that stupid func breakable...
     
  11. henke37

    aa henke37

    Messages:
    1,909
    Positive Ratings:
    446
    The number is the brush id. As such the go to brush id command should work.
     
  12. Benoist3012

    Benoist3012 L3: Member

    Messages:
    147
    Positive Ratings:
    201
    This ^ and use a logic_auto to kill these "precache" entities so you don't waste edicts.
     
  13. Qbus

    Qbus L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    killing with logic auto didn't work for me.
    when I add the *1000 to my logic auto and i click to select the brush then almost every door is getting selected. strange coz problem is about func_breakable.

    oh forgot to say. I can't even load the map in tf2
     
  14. ϺΞΤЯΘΉλϺ

    ϺΞΤЯΘΉλϺ L3: Member

    Messages:
    102
    Positive Ratings:
    54
    Could you provide a screen shot?
     
  15. Qbus

    Qbus L1: Registered

    Messages:
    9
    Positive Ratings:
    1
  16. henke37

    aa henke37

    Messages:
    1,909
    Positive Ratings:
    446
    Don't kill the brush. Kill the precache entities.
     
    • Agree Agree x 3
  17. Qbus

    Qbus L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    ok deleted func_breakable replaced them with buttons.
    thread can be closed.
    btw thx for helping me guys.
     
    • Agree Agree x 1