I can't turnoff cheats

Discussion in 'Mapping Questions & Discussion' started by Robot3x, Sep 16, 2011.

  1. Robot3x

    Robot3x L2: Junior Member

    Messages:
    51
    Positive Ratings:
    3
    I enabled cheats so I could enter mat_wireframe to see what was being rendered. I turned off the wireframe, and when I turn off cheats everything goes dark. I have been running fullbright because I don't have light entities yet aside from environment and turn that off so it isn't dark inside. It seems turning off cheats turns off fullbright. I then typed fullbright 1 and it said it couldn't do it because cheats were turned off.

    When I start the game again every time, this message is in the console:
    Achievements disabled: cheats turned on in this app session.

    But I keep setting cheats to 0. I did get an item while testing though since doing all of this. Never got one before but have gotten achievements in the past. So getting items isn't disabled apparently.

    I'm confused. I don't know what's going on. I was nervous enabling cheats because I don't want to inadvertently get banned from playing because I don't know what I'm doing.

    So are the cheats turned off? Or does it automatically turn on cheats to do fullbright? Or does it consider the console a cheat? Why am I getting that message?
     
    Last edited: Sep 16, 2011
  2. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,767
    Usually if you run a map after compile the game loads up in DEV mode so cheats will be turned on. Having cheats on wont get you banned and only works in LAN games. Servers run their own individual configs which force cheats off unless they have plugins to do otherwise. VAC bans are based on the detection of third party software that modifies game files so you are safe.

    It's strange that the game would "remember" your cheats being on and save that to your config, usually configs are only temporarily overwritten for that session. To save particularly configs perminantly you have to edit the file manually. Especially for it then not to save sv_cheats 0 the second time you load the game and turn them off. To force sv_cheats to 0 you'll want to open yourconfig file in your tf directory and find the entry "sv_cheats" and save as "0" and tell the file to be "read only" if it is not already (Though if it was already then it shouldn't save "sv_cheats 1" in the first place).
     
    • Thanks Thanks x 1
  3. Robot3x

    Robot3x L2: Junior Member

    Messages:
    51
    Positive Ratings:
    3
    So when you run the map in DEV mode, it automatically turns cheats on?

    I haven't been running it before with -dev -console. I just started doing it for the cheats. I had only been using -sw +sv_lan 1 in the Additonal Parameters section.

    Since I wasn't using -dev -console is that why I kept getting achievements while testing my map?

    If it automatically turns cheats on in Dev mode, wouldn't that be why I am getting that message? Or is that an unusual message?

    When I put in sv_cheats 0, I do get a message that says something like "CVAR set to defaults". And my map goes dark.
     
  4. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,767
    Honestly i havn't used these settings in a while, i tend to clear out my RAM between using Hammer and TF2 so things run more smoothly. IE i don't run TF2 directly after compiles and fullbright has always worked for me with sv_cheats initially set to off. What i don't understand is how your map retains its pitch-blackness even after re-starting TF2 and i thought it might have had something to do with going between dev mode and running TF2 normally as there's no reason for your config to be retaining those settings and buggering up your maps lighting. DEV mode is the only variable i could predict in this scenario and what i'd end up troubleshooting.

    The only thing i can suggest is running another map first and then returning to your map as this clears your memory cache as sometimes it can be retained even after restarting the game.
     
    • Thanks Thanks x 1
  5. Robot3x

    Robot3x L2: Junior Member

    Messages:
    51
    Positive Ratings:
    3
    Sorry, I was unclear. My map doesn't go dark until I had put in sv_cheats 0. When I restart everything is back to normal except that message, which I thought maybe meant cheats were turned on permanently in my game somehow.

    But if I understand correctly now, it just means cheats are on because the dev console is on. So when I play normally it won't turn on the cheats and in any case the servers will turn it off automatically.
     
  6. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,494
    Positive Ratings:
    321
    If you're just testing the map out and not running full vis for every compile try it this way:

    Start tf2 - run it in a widow - slightly smaller than your monitor setting(doing it this way allows you to flip back and forth between your game and hammer quickly.

    Start up hammer, then do F9 to run compile - select normal (not advanced) and check off the box that says don't rn game after compiling.

    Once compile is complete - run your map in tf2 - either by create server or via cosole command "map your_map_name" <your map name is the name of the map you're working on.

    you can turn cheats on/off and mat_wireframe quite easily although I don't know if there's any other issues in doing it this was - it just seems to work for me.
     
    • Thanks Thanks x 1
    Last edited: Sep 16, 2011
  7. Empyre

    Empyre L6: Sharp Member

    Messages:
    298
    Positive Ratings:
    173
    If you're testing your map and you want fullbright, skip vrad. Your compile will be a little bit faster, too.
     
    • Thanks Thanks x 1