I can't seem cubemaps, but I know they are there

Discussion in 'Mapping Questions & Discussion' started by Werewolf, Sep 5, 2014.

  1. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    781
    Positive Ratings:
    226
    Recently I seem to have stopped seeing cubemaps in my own map. I compile the map, build the cubemaps and I see them. All is good. Now I know that when I do this, Hammer puts my compiled map in my Team Fortress 2\tf\download\maps folder, but when I build cubemaps a new copy of the .bsp file is created in Team Fortress 2\tf\maps.

    Because the map I have been making has been uploaded to a server, I move the version of the map in the Team Fortress 2\tf\maps folder to my Team Fortress 2\tf\download\maps folder, and also upload a copy of that same version to the server.

    The thing is, once I have uploaded it to the server I no longer see the cubemaps. Other people do which I know from their comments and screenshots. What I want to know is why don't I? I have the original files but I see a cubemap-less map.

    Anyone got any idea why this happens?

    EDIT: The title should say "I can't see cubemaps, but I know they are there", instead of "seem"
     
    Last edited: Sep 21, 2014
  2. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    So Hammer puts your map in tf/download/maps and you have a copy of the map in tf/maps? Sounds to me as something that could confuse the game.
    And why dont you tell hammer to simply put your compiled maps to tf/maps?
     
  3. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    781
    Positive Ratings:
    226
    I only end up with a copy in the tf/maps folder after I build cubemaps. Once I upload the cubemapped version to the server, I have to delete the version in my tf/download/maps folder because if I join the server it would tell me my version of the map differs from the servers version.

    Even if I leave the copy with cubemaps in the tf/maps folder, it would still download the map to the tf/download/maps folder when I join the server, and I dont see the cubemaps.
     
  4. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    I feel like you are doing something wrong at this part.

    If you only have one copy, it doesn't matter if it is in tf\ or tf\download or tf\custom, the game will see it and load it and not download a new one.

    The one placed in tf\maps after you build them is the one you want, and the one that has cubemaps in it. Maybe you just have specular off..? are you seeing no reflections, or missing reflections? (matte finish vs shiny purple)
     
  5. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    781
    Positive Ratings:
    226
    I have always followed this guide on building cubemaps, and before loading another map I always turn mat_specular back to 1.

    Like I said, once I have then reloaded my map it shows the cubemaps so I know they are being made, and other report seeing them once on the server.
     
  6. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    781
    Positive Ratings:
    226
    Well I seem to have found a fix, though not sure why I have to do it.

    Basically if I dont see cubemaps, I just have to type mat_specular 1 and I can see them again. The thing is, I run TF2 on its max settings so I should see them already. Unless there is a hidden setting someone can point me to, this is just something I will have to add to my autoexec.cfg file.
     
  7. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    You must have turned them off at some point; it is part of the set of commands for building cubemaps, after all.
     
  8. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    781
    Positive Ratings:
    226
    But as I stated above, I always turn them back on again.
    For whatever reason, the don't seem to be on by default for me.
     
  9. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    Did you check if your config.cfg is read-only?
     
  10. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    947
    Positive Ratings:
    930
    I never see shiny purple. Missing cubemaps always turn into the default cubemap.
     
  11. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    393
    You might have had mat_specular 0 set at some point and exited the game, which will write that setting to config.cfg making it "permanent."

    Look at config.cfg to see if that's the case, and adjust as necessary. Or nuke the file, there's not much in there that's important (because everything you value should be in autoexec.cfg). Or run TF2 with the -autoconfig option to reset everything to a safe default.
     
  12. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    You mean you put every custom keybind and setting into autoexec? That seems like needless duplication... that's what config.cfg is there for.
     
  13. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    393
    Yes, but TF2 overwrites config.cfg constantly.. the last modified timestamp probably matches the last time you played TF2. autoexec.cfg on the other hand is never modified by TF2 (unless a cloud restore mucks with it) so it's a less volatile place to store customizations.
     
  14. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    781
    Positive Ratings:
    226
    I've never changed that setting on it. I looked just now and read-only is off, which I presume is how it should be as TF2 would not be able to save changes if you re-bound a key.