I can't compile anymore

Discussion in 'Mapping Questions & Discussion' started by Vincent, May 16, 2010.

  1. Vincent

    aa Vincent 🔨 Grandmaster Lizard Wizard Jedi 🔨

    Messages:
    914
    Positive Ratings:
    580
    So I was working on a map one day and prior to an update all my compiling was fine. Doing a simple routine map test I tried compiling, vrad crashed 3 times. A little frustrated I restarted Hammer, I had really really bad vrad errors in my map. Deleting everything but the .vmf I tried recompiling, I got an error saying it couldn't find the .bsp. I said screw it, copied all my geometry over to a brand new .vmf (I left out things like my lighting and my payload cart), tried compiling again and it said I couldn't find the .bsp.. On a completely new map.

    I quit mapping for a few days, came back yesterday and opened up a new file. About a day worth of decent work I save it and hit compile, just to get this.

    [​IMG]

    Trying various things to fix it like doing a skybox around the whole map for example, nothing worked. It couldn't find the .bsp. This makes absolutely 0 sense since there never was a .bsp in the first place. I reinstalled Hammer and it didn't fix anything. Then I tried compiling nothing, just black void, and I got this.

    [​IMG]

    I hit cancel just to get this.

    [​IMG]

    This is really depressing, being able to map but not being able to playtest and see my progress sucks to say the least.

    Any idea's on how to fix this?
     
  2. The Political Gamer

    aa The Political Gamer

    Messages:
    4,468
    Positive Ratings:
    1,684
  3. Boylee

    aa Boylee pew pew pew

    Messages:
    1,068
    Positive Ratings:
    631
    I've had this error crop up before but unfortunately I've never been able to identify it's cause as it's usually fixed itself for reasons unbeknownst to me.

    You could try verifying your came cache for both TF2 and Source SDK, assuming you haven't already done so.

    I have this vague feeling that it might actually be a Windows error not a Hammer one. I know it's a stupid question but have you tried restarting? Failing that have you tried saving the vmf somewhere where Windows can find it easily? (e.g. like in the root of C:/ )
     
  4. Porkchop

    Porkchop L1: Registered

    Messages:
    42
    Positive Ratings:
    11
    Last edited: May 16, 2010
  5. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,623
    Positive Ratings:
    1,712
    the basic process is that bsp creates the file with all the geometry and stuff, than vvis calculates visibility according to what bsp has created, then vrad calculates the lightning based upon what's in your .bsp.
    if vrad can't find the .bsp, bsp.exe is the faulty bastard.
    find what's preventing bsp to complete and you should be good to go.

    also, compile log plz?
     
  6. Engineer

    aa Engineer

    Messages:
    1,166
    Positive Ratings:
    372
    When i get this error, its always the same problem - either a leak or some faulty displacements.
     
  7. Steff0o

    Steff0o L6: Sharp Member

    Messages:
    295
    Positive Ratings:
    115
    You got a error, it happens in the vbsp process, just make sure that your map doesnt contain any errors and run the compile again.
    for finding the errors you can use the Interlopers error check site
     
  8. Vincent

    aa Vincent 🔨 Grandmaster Lizard Wizard Jedi 🔨

    Messages:
    914
    Positive Ratings:
    580
    I haven't had a chance to try any fixes but I'll get back to it as soon as I can get home.

    As for problems, my map doesn't have a leak or faulty displacement (Doesn't have any displacements at all actually). I completely covered my map in one massive skybox box, there's absolutely no way there's a leak.
     
  9. Nutomic

    Nutomic L11: Posh Member

    Messages:
    888
    Positive Ratings:
    177
    No, please tell me it was a joke D:
     
  10. Codename22

    Codename22 L1: Registered

    Messages:
    46
    Positive Ratings:
    20
    I had this too since the sdk update...
    I fixed it by saving my vmf in my steamapps folder.
    For some reason it can't handle paths with dots in it anymore so if your account name (usually your email) contains a dot then it will fail.
    Just try it in a different folder... it worked for me... hopefully it works for you too :)
     
    • Thanks Thanks x 1
  11. Vincent

    aa Vincent 🔨 Grandmaster Lizard Wizard Jedi 🔨

    Messages:
    914
    Positive Ratings:
    580
    I don't do that normally, I just did it to check for any leaks to see if that was the problem. I know it's not a good idea to do that. TERRIBLE optimization.
     
  12. Vincent

    aa Vincent 🔨 Grandmaster Lizard Wizard Jedi 🔨

    Messages:
    914
    Positive Ratings:
    580
    Changed my directories on my map, even though it doesn't have a dot it shouldn't have done anything to prevent me from compiling. It worked finally though.

    Thank you.