How come my cubemaps won't work in TF2??

Discussion in 'Mapping Questions & Discussion' started by ShroudedSiege, Oct 3, 2008.

  1. ShroudedSiege

    ShroudedSiege L1: Registered

    Messages:
    27
    Positive Ratings:
    6
    Well i know how to create custom cubemaps for my textures and such but if i try to use them in TF2 engine they seem to have no effect but in the HL2 engine they work great :blink:

    I haven't changed anything in the .vmt file, i simply created the textures in the appropriate folders.

    Here's my .vmt file:
    "LightmappedGeneric"
    {
    "$basetexture" "project/tilebasetexture"
    "$bumpmap" "project/tiletestbump"
    "$envmap" "env_cubemap"
    "$envmapcontrast" 1
    "$envmapsaturation" 1
    "$envmaptint" "[ .75 .75 .75]"
    }



    Like i said nothing has changed at all but it just won't work on the EP2 engine for some reason which is really annoying because i'm a mapper and 3D model artist and it's kinda made me hit a dead end until i can figure out what's wrong..

    Thanks for your help :thumbup1:
     
  2. MrAlBobo

    MrAlBobo L13: Stunning Member

    Messages:
    1,059
    Positive Ratings:
    219
    heres a valve made texture affected by cubemaps that ive had sitting on my desktop for the longest time
    you appear to lack the "$normalmapalphaenvmapmask" 1 whatever the hell that means...
     
    Last edited: Oct 3, 2008
  3. TheDarkerSideofYourShadow

    TheDarkerSideofYourShadow L10: Glamorous Member

    Messages:
    792
    Positive Ratings:
    143
    I believe that line tells the engine that the specular map is an alpha layer of the normal map.

    From my understanding, you can either put the specular map in the actual texture, or in the normal map. However, if you have a normal map, then it MUST be in the normal map. There are special lines to add depending on what you do (Al listed one there).
     
  4. ShroudedSiege

    ShroudedSiege L1: Registered

    Messages:
    27
    Positive Ratings:
    6
    I have a normal/bump map and the alpha is added to that and saved with it. That is what i have been doing up until now and it worked for the EP1 engine...
     
  5. Cerulean

    Cerulean L3: Member

    Messages:
    112
    Positive Ratings:
    59
    fixed!

    added "$normalmapalphaenvmapmask" 1

    but the real problem was just weird (note the checkboxes, left one is the one that worked. Exported as 'compressed texture' from photoshop):

    [​IMG]

    [​IMG]
     
    Last edited: Oct 3, 2008
  6. Snipergen

    Snipergen L13: Stunning Member

    Messages:
    1,053
    Positive Ratings:
    150
  7. ShroudedSiege

    ShroudedSiege L1: Registered

    Messages:
    27
    Positive Ratings:
    6
    I do have a normal map though i used the NVIDIA plugin to create it and it's purple/blue =-/
     
  8. TheDarkerSideofYourShadow

    TheDarkerSideofYourShadow L10: Glamorous Member

    Messages:
    792
    Positive Ratings:
    143
    Thats what color normal maps are supposed to be :)
     
  9. Zeewier

    Zeewier L9: Fashionable Member

    Messages:
    619
    Positive Ratings:
    130
    Also make sure it's in the Alpha channel